Here's how I resurrected my Pismo's "dead" laptop DVD-ROM Drive.

Recently I placed a CD in the DVD-ROM (Model M7931, Apple P/N 661-2244) drive on my G3 Pismo laptop to install some software. I heard some slow and fast spin sounds, but the CD icon did not appear on the Desktop. I removed the CD and inserted a DVD, but got the same results. The drive's lens was clean and the drive appeared in the System Profiler. When I replaced the DVD-ROM drive with a CD-ROM drive (M73888), the CD drive read a CD, so apparently the electronics within the G3 were OK.

I did some Google searching for possible solutions. I read in several forums that these DVD drives have been problematic, primarily with a failed motor. Looking on eBay and some Mac hardware sites revealed that used ones appear to cost $50+ and new ones about $100+. The Service Manual troubleshooting doesn't suggest much, except replace. I thought there might be an alternate (cheaper $) PC drive that could be used. I found this site Replacing or Upgrading the Optical Drive in Your PowerBook G3 or 1400
http://lowendmac.com/rivera/06/0124.html that suggested replacing the Apple drive with a PC drive. Also Googled this site. PowerBooks Lombard (1999) and Pismo (2000) optical Expansion Bay Module drive replacement and interface PCB modification http://mywebpages.comcast.net/macdan..._EBM_sled.html

I decided that since I had a CD-ROM drive, I probably would not spend $ for an Apple drive at this time, but I might look for a PC drive.

In the meantime, I thought that since the drive was inop and possibly need to be trashed, I was not adverse to trying to disassemble and attempt a repair.

There are 3 things in the arsenal of most guys (and many gals) to fix problems - use WD-40 lubricant, use duct tape and/or use bailing wire. It seemed that the tape and wire were not viable solutions for this problem.

I opened the drive tray from it's enclosure. Using a #0 jeweler's Phillips screwdriver, I removed the metal cover plate screws (5). Then removed the screws (3) holding the motor/plate assembly. I carefully lifted the motor assembly upward at about a 45 degree angle (flex cables were attached). Looking at the side, there was about a 1mm gap between the motor & the plate. Using the plastic nozzle on a can of WD-40, I sprayed a small amount of lubricant. Let it sit for a few minutes and rotated the spindle. Reassembled everything.

I inserted a CD, didn't hear any spinning noise and the CD icon appeared on the screen. Repeated with a DVD. Both were being read. Yea!!!!!!!!!!!! It's fixed. WD-40, the miracle solution. How long it will last? I don't know, but for now it's working. May not work for other models or different types of failures.

Cheers, Tom