Follow us on...
Follow us on Twitter Follow us on Facebook
Register
Results 1 to 5 of 5
  1. #1
    Stridder44's Avatar
    Stridder44 is offline Universal Traveler
    Join Date
    Nov 2002
    Location
    Cali
    Posts
    661
    Thanks
    0
    Thanked 0 Times in 0 Posts

    StarCraft latency issues...need help please!!

    Every time I try and host a game in StarCraft, it says I have too high a latency for other people to join, much less for me to host (I can make the game but no one will join). And every time I try and join another game, it will always lag. I usually figure it must be someone else because I have DSL and SC should not be a problem. However, I was just in a game and someone was lagging and it asked if I wanted to drop the player, so I did, and when I did, Everyone was kicked but me. So now Im beginning to think there is some setting on my Mac that's giving me high latency (i.e., a firewall maybe?). I have a Router so that might cause problems. But can anyone help?
    http://www.realultimatepower.net/...Are you ready to get pumped!!?

  2. #2
    Vash137's Avatar
    Vash137 is offline Registered User
    Join Date
    Dec 2001
    Location
    2nd Earth
    Posts
    19
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I am not sure, but I do not think Starcraft will work behind a router. I remeber that problem that I had when trying to play behind Airport. I am sure though, that 2 people behind one router can not do SC battle.net at the same time. (even with different CD-Keys) Check the blizzard site's FAQ on Starcraft and routers.

  3. #3
    Trip's Avatar
    Trip is offline Registered User
    Join Date
    Sep 2001
    Posts
    3,243
    Thanks
    0
    Thanked 1 Time in 1 Post
    Wow, i've only heard of that happening with a 56k.
    Don't know what to tell you.

  4. #4
    Stridder44's Avatar
    Stridder44 is offline Universal Traveler
    Join Date
    Nov 2002
    Location
    Cali
    Posts
    661
    Thanks
    0
    Thanked 0 Times in 0 Posts
    yea, it's bizzare for me too.......
    http://www.realultimatepower.net/...Are you ready to get pumped!!?

  5. #5
    MDLarson's Avatar
    MDLarson is offline Registered User
    Join Date
    Feb 2002
    Location
    Minneapolis, MN
    Posts
    1,194
    Thanks
    3
    Thanked 3 Times in 3 Posts
    I run Starcraft on B.net behind a Linksys router, and everything functions normally for me. I have experienced the same symptoms you have, Stridder, but it's been rare.

    --->>> B.net screen name: MacUzer (I usually play b.net west)

 

 

Similar Threads

  1. Dialer issues
    By blotto in forum Mac OS X System & Mac Software
    Replies: 0
    Last Post: January 19th, 2003, 12:38 AM
  2. Help: Starcraft under 10.2
    By chevy in forum Mac OS X System & Mac Software
    Replies: 0
    Last Post: October 7th, 2002, 02:44 PM
  3. Quicktime 6 demoed, but delayed because of licensing issues
    By simX in forum Apple News, Rumors & Discussion
    Replies: 15
    Last Post: February 14th, 2002, 05:46 PM
  4. Version Tracker Has Starcraft!!
    By Soapvox in forum Mac OS X System & Mac Software
    Replies: 0
    Last Post: November 21st, 2001, 12:41 PM
  5. dock issues...
    By bolindilly in forum Apple News, Rumors & Discussion
    Replies: 3
    Last Post: April 8th, 2001, 11:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •