Follow us on...
Follow us on Twitter Follow us on Facebook
Register
Results 1 to 2 of 2
  1. #1
    Greg_Reez's Avatar
    Greg_Reez is offline Registered User
    Join Date
    Jun 2008
    Location
    Northern California
    Posts
    134
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Can't Quit Preview (It's Locked Up)

    I rarely use preview for anything but this time I double clicked a file from a CD that just happened to be a 500mb tif. Preview began launching, but now it is not responding, like its basically frozen. I right clicked the icon in the dock to force quit, nothing. I opened the Force Quit Applications window, highlighted Preview (which is red and says not responding) clicked force quit, nothing.

    So I decided to eject the CD which I can't because it says the disk is in use. I tried to shut my computer down which I also can't, because it says that Preview isn't shutting down.

    Please help, how can I quit the program or shut down my system so I can take the CD out?

    * Tried quitting the process via activity monitor... nothing.

  2. #2
    ElDiabloConCaca's Avatar
    ElDiabloConCaca is offline U.S.D.A. Prime
    Join Date
    Aug 2001
    Location
    San Antonio, Texas
    Posts
    14,518
    Thanks
    10
    Thanked 651 Times in 613 Posts
    You can "kill it with impunity" via the Terminal.

    Open Terminal, then use either 'ps' or 'top' to get the PID ("Process ID") of Preview.app.

    Then, in Terminal, type "sudo kill -9 PID" where PID is the PID of Preview.app. Type in your admin password, and it should kill it.
    2009 Mac mini 2.0GHz 2010 MacBook Air 11" 2010 MacBook Pro 13" LED 24" Cinema Display
    PowerMac G4 MDD dual 1.25GHz PowerMac G4 Yikes! iPad 2 32GB 2 x iPhone 4 16GB iPod Touch 8GB iPod nano 1GB iPod shuffle 1GB AirPort Extreme dual-band AppleTV
    http://www.jeffhoppe.com

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •