Follow us on...
Follow us on Twitter Follow us on Facebook
Register
Page 1 of 2 12 LastLast
Results 1 to 8 of 9
  1. #1
    donniecrunch is offline Registered User
    Join Date
    Oct 2011
    Posts
    5
    Thanks
    3
    Thanked 0 Times in 0 Posts

    system preferences / desktop picture / stuck loading images

    mac air 10.7.2
    when i open 'system preferences / desktop and screen saver' i get the spinning beach ball and it never stops, with status: loading images. i had accidentally clicked on a folder inside iphoto containing hundreds of pictures, instead of my desktop images folder. now nothing in the window is clickable. can force quit out of it but the ball starts spinning again on re-entry as it attempts again to load images. tried restart and also safe start, ball spinning again on reentry to this syspref window. i've waited an hour. would like to terminate the attempt to load images so i can click the correct folder and be on my way. thanks for any help offered.

  2. #2
    Satcomer's Avatar
    Satcomer is offline In Geostationary Orbit
    Join Date
    Jul 2002
    Location
    Finger Lakes Region
    Posts
    9,108
    Thanks
    57
    Thanked 402 Times in 385 Posts
    In Lion follow these steps:

    1. Quit all programs then click on an empty part of the desktop until the only the 'Finder' is in the menu bar.

    2. Hold down the 'option/alt' key while click on the menu item 'Go'. Then while still holding down the option/alt key select 'Library'.

    3. When Library opens scroll to the folder for "Preferences" and open it.

    4. In Preferences find the file: com.apple.systempreferences.plist and move that file to the desktop.

    5. Launch System Preferences->Desktop & Screensaver and try again to see if it is fixed. If this doesn't fix it close System Preferences, follow the steps back to the Library->Preferences and put that file back. If it work you can just trash that file and smile.

    Good Luck.
    Mac Pro Dual 2.8 Quad (2nd gen), 14G Ram, Two DVD-RW Drives, OS X 10.9.1
    2006 Mac Book Pro 2.16 (first Gen) OS X 10.7.5
    2TB Time Capsule, 2 TB
    Black, iPad (3rd Gen) 32G Black

  3. The Following User Says Thank You to Satcomer For This Useful Post:

    donniecrunch (October 14th, 2011)

  4. #3
    donniecrunch is offline Registered User
    Join Date
    Oct 2011
    Posts
    5
    Thanks
    3
    Thanked 0 Times in 0 Posts

    thanks but no luck

    Thanks for your help, Satcomer. I really appreciate your time.

    I carefully ran through your checklist but the result was the same: spinning ball and 'loading images' status. I was going to replace the plist file I had put on the desktop but noted that there was now a shiny new one already in place in the folder so left it there instead. I also tried opening syspref/desktop after having put the equivalent plist lockfile on the desktop too, but again, no luck. That file was also immediately replaced upon reopening the syspref window.

    I have about 1700 photos in iphoto and it feels like the syspref desktop window wants to load them all before proceeding. This problem began when I accidentally clicked on a folder containing all of my photos from within syspref/desktop, instead of clicking on my desktop pictures folder. Is there a way to stop syspref/desktop from doing that and have it just load the 25 images in my desktop pictures folder? And why does it want to load them all even after a reboot, if that's what it's doing? I can understand it hanging first time, but not subsequently.

  5. #4
    Satcomer's Avatar
    Satcomer is offline In Geostationary Orbit
    Join Date
    Jul 2002
    Location
    Finger Lakes Region
    Posts
    9,108
    Thanks
    57
    Thanked 402 Times in 385 Posts
    Then try the same steps for the Preference file: com.apple.desktopscreensaver.rsspictures.plist . See if that helps.
    Mac Pro Dual 2.8 Quad (2nd gen), 14G Ram, Two DVD-RW Drives, OS X 10.9.1
    2006 Mac Book Pro 2.16 (first Gen) OS X 10.7.5
    2TB Time Capsule, 2 TB
    Black, iPad (3rd Gen) 32G Black

  6. The Following User Says Thank You to Satcomer For This Useful Post:

    donniecrunch (October 14th, 2011)

  7. #5
    donniecrunch is offline Registered User
    Join Date
    Oct 2011
    Posts
    5
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Tried that, thanks. No luck. I noticed that the small grey pinwheel beside 'loading images' in the syspref>desktop window was not even moving, so I looked in the Activity Monitor and SysPref was showing in red as unresponsive. I assume this means it hasn't been busily loading images while the beach ball spins, but rather just frozen. Forced quit out of it.

  8. #6
    Satcomer's Avatar
    Satcomer is offline In Geostationary Orbit
    Join Date
    Jul 2002
    Location
    Finger Lakes Region
    Posts
    9,108
    Thanks
    57
    Thanked 402 Times in 385 Posts
    Try signing out of System Preferences->iCloud and then signing back in. Also check to make sure you have Photo Streaming check-marked.
    Mac Pro Dual 2.8 Quad (2nd gen), 14G Ram, Two DVD-RW Drives, OS X 10.9.1
    2006 Mac Book Pro 2.16 (first Gen) OS X 10.7.5
    2TB Time Capsule, 2 TB
    Black, iPad (3rd Gen) 32G Black

  9. The Following User Says Thank You to Satcomer For This Useful Post:

    donniecrunch (October 14th, 2011)

  10. #7
    donniecrunch is offline Registered User
    Join Date
    Oct 2011
    Posts
    5
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Thanks for the idea. But I'm not using iCloud. Haven't activated it.
    I've noted that when I open the syspref/desktop&screensaver window, the 'loading images' status is already displayed. There is no time lag at all. It's like it's locked there from before. Also, I have cursor movement control for 5-7 seconds, but it is unresponsive to any clicking. Then the cursor is replaced by the beachball.

  11. #8
    donniecrunch is offline Registered User
    Join Date
    Oct 2011
    Posts
    5
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Found a useful thread on Apple Support that describes my problem and offers a couple of solutions:
    - moving iPhoto Library outside the picture folder;
    - another: Go to Applications > System Preferences, and then "Get Info". Unchecking "Open in 32-bit mode".
    Neither worked for me.

 

 
Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •