Follow us on...
Follow us on Twitter Follow us on Facebook
Register
Results 1 to 2 of 2
  1. #1
    ahaha is offline Registered User
    Join Date
    Sep 2006
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Cannot Open Port 80 To Lan Ip Address

    We run a Java-based server for a horrible application called Maconomy behind a D-Link (DI-808HV) Firewall Router that is behind an AT&T Cisco T1 router. I have opened Port 80 to that server's IP address (192.168.1.4) but all port scans show it as closed. It is the only way we can connect to Maconomy from external networks. A port scan of the LAN side of the D-Link router (at 192.168.1.2) shows Port 80 open. I have enabled Port 80 in both the Virtual Server function as well as the Firewall settings of the D-Link.

    Someone Pl-e-e-ease help! Thanks!

  2. #2
    Yesurbius's Avatar
    Yesurbius is offline Registered User
    Join Date
    Jan 2001
    Location
    Edmonton, Alberta
    Posts
    168
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Okay! First lets clear up your network topography.

    Server (192.168.1.4) -> D-Link Firewall (192.168.1.2) -> T1 Router

    There are so many points of failure in this setup. It could be the server configuration, D-Link Firewall Configuration, T1 Router, or even the upstream provider.

    1) First, Take a laptop (or another computer) and connect it in peer to peer mode to the server (crossover cable) - setup a DHCP server on laptop or do static IP for testing purposes. See if you can access port 80 (telnet 192.168.1.4 80) If you can't access it, then check the application settings to ensure its open and enabled. Check the OS firewall (ip filter). Once you get that working, hook it up to the D-Link and try again.

    2) If you can connect to the server on port 80, but not when connected to the D-Link Firewall, then unplug the firewall from the t1 and connect the laptop to the D-Link Firewall. Test for port 80 (telnet 192.168.1.2 80). If not working, check your firewall configuration. Once you get that working, hook it up to the T1 and try again.

    3) If STILL not working - check your T1 router config (although more than likely at this point you'lll be contacting the ISP/Telco).

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •