Search results

  1. G

    Using iPod on Lombard

    I've recently bought a 20GB iPod Photo and just found out that it requires a USB 2.0 connection which needs OS X 10.3.4 to operate. I'm running 10.2.8 and have no FireWire capabilities on the '00 Lombard I'm using. Can I still use the iPod despite having the older USB ports or have I...
Top