Battery of Ibook G4 Won't Charge

delmar78

Registered
Recently, the battery of my iBook G4 (OS 10.4.2) stopped charging. The light on the power cord does not change to orange, but remains green. With the power cord plugged in, the battery fortunately does not drain.
I tried several things: I did reset the PMU (power management unit) with no result. I swapped the power cord and battery with a colleague's, also with no result. In his iBook, my battery and power cord worked fine (ie charged), but in my iBook his battery and power cord would not charge.
In the system profiler, my battery seemed to be fine: maximum capacity was 4144mAh (of a max of 4400 when the battery is new).
However, a few lines below the one about the battery capacity, system profiler has a strange line (I translate this from dutch):
"Power adaptor can not charge battery: yes"
If I could change this "yes" into a "no", it seems that my problem would be solved. Does anybody have a clue how to solve this problem?
 

neilroskilly

Registered
I have the same problem with my ibook. The light on the end of the adapter cord remains green, but the battery indicator indicates no charge left. I need to keep the thing plugged in to use, so no portability. System profiler doesn't give me the information you describe - nothing about the battery that I can see.
 

delmar78

Registered
Well, I had to bring in my iBook to a service center and they replaced the DC-in board which was somehow broken. Because you regularly plug in and unplug the power cord, this is a part which is very sensitive to failure.
Repairing it isn't cheap: I paid about 150 euros, which comes down to $180. But at least my boss was paying...:D
 
Top