Comcast Email Problem with Mail

dixonbm

Registered
Is anyone else having problems getting their comcast email in Apple's Mail.app? This same thing happened to me about a month ago and after about 5 days it just started working again.

What happens is that it acts like its connecting and then it gets stuck on "Preparing to Retrieve Messages" Fat chance, it doesn't do anything but eventually stop trying to "retreive messages.

I called comcast and apple last time this happened, they blamed it on each other. I can get my email fine in Entourage and via webmail. My other email accounts with .mac work fine as does my wife's comcast email. It's weird. Last time I even tried on other computers and a different user...all the same result. Any ideas?

I really don't want to call Comcast again, their tech support knows about as rock about macosx.

Thanks!
 

GraphicUmp

Registered
Yep. Same here. For about 24 hrs.

But some time while I was at work yesterday, it fixed itself and now it's as fast as ever. Weird.....
 

bobw

The Late: SuperMacMod
Not Comcast's fault, it's Mail. Use a different program. I've been using Eudora for years and never have problems like this.
 

DeltaMac

Tech
I was also assuming the problem was in Mail, but if you go to Comcast Cust (cussed?) Service page, you'll find multiple report from customers (cussed-tomers?) reporting problems accessing Comcast mail servers for the last couple of days. (I have also been having trouble downloading mail) I had actually deleted all traces of Mail, reinstalled and copied backups of my old Mail folders before checking at the Comcast site. Ah well, Comcast explains that they are aware of problems with their servers for the last couple of days, (and will be better soon) and now my Mail is working as always :) :rolleyes:
 

dixonbm

Registered
While I was on the phone with comcast last night they had me login to the webmail like I told them I could and I decided to delete some stuff on there I didn't work. Immediately the next time I tried to get email in Mail it worked!! Comcast didn't have a clue. Something to do with the email on the server and Apple's Mail. Entourage could download it fine.

Anyone else able to replicate this?

Please explain your problems more...those who have problems with Mail that is.
 

dixonbm

Registered
It's back!!!

I hate comcast email. It's something with their mail server. I tried logging into webmail a few times but it kept saying login failed. After the third attempt it still said login failed but it finally let me into the message list.
 

bobw

The Late: SuperMacMod
Download Eudora and try that. You can use it for free and you won't have any problems like this.
 

dixonbm

Registered
I'll try eudora, but I didn't really care for the interface. As for entourage I like it except for the way it does the text. I love the Mail displays the text.
 

imnokid

Registered
My Mac mail has been bad for a week. Numerous calls to comcast.
My inbox has a lock on it. I am able to send mail, but not receive.
And I cannot delete mail, getting message that
Deleted messages - pop account does not allow messages to be moved to it.
When running connection doctor, it shows no connection to POP account.

All of my mail preferences are set correctly.
I am able to get my incoming mail at the comcast site, but what a HASSLE!!!!!

Anybody have any suggestions?
 

Satcomer

In Geostationary Orbit
My Mac mail has been bad for a week. Numerous calls to comcast.
My inbox has a lock on it. I am able to send mail, but not receive.
And I cannot delete mail, getting message that
Deleted messages - pop account does not allow messages to be moved to it.
When running connection doctor, it shows no connection to POP account.

All of my mail preferences are set correctly.
I am able to get my incoming mail at the comcast site, but what a HASSLE!!!!!

Anybody have any suggestions?
I guess this is your ISP email server, right? If the pop server is past your Comcast server and change your POP server from port 25 to 587 and that might fix it.
 

Satcomer

In Geostationary Orbit
Well since you ignored by request for more information about what email you were getting well do this the Geeky way:

1. Quit Mail
2. Right down your email settings and go to your comcast site to verify the email server settings (it is import to verify the settings!!!).
3. Go to the folder /YouHardDrive/Users/YourUserName/Library/Preferences/ and delete the file com.apple.mail.plist (you will not lose email so be calm)
4. Open /Applications/Utilities/Keychain Access and in that application do a search for saved passwords for the Comcast email POP server and delete thos files.
5. Open Mail and it's Preferences file and push Accounts tab. In there setup the Mail settings again for Email (by the settings you verified from Comcast because they maybe using SSL or a different port). Also let the email stay on your sever for a day or so. This way you can always right click on the Inbox and look inside the POP email server at you messages in waiting).

If this doesn't work (after you VERIFIED the email server settings from Comcast itself). Doing it manually instead of the Connection Doctor is a little more stable in my book.

Note: I am almost sure that Comcast uses SSL on a special port.
 
Top