Bootcamp gone bad, Mac HD GONE

smurfed

Registered
So I was installing Windows XP via bootcamp, and chose Drive C to format it in , but that was weird cause it didnt show any of the usual other drives, It only showed NTFS, so I selected that.

After it was done installing it did the usual reboot, and after it rebooted all i get is the gray screen of death.

I rebooted it again holding down the option key to select which partition to boot from and... ALL PARTITIONS WERE GONE
The Mac HD partition was gone, all I saw was the installation disc.

So i thought i would just reformat the whole drive and reinstall Leopard, but while i was doing that, when it gets to the step "Select a destination to install Mac OS X" Nothing is listed, no drives to choose from, and it cant continue the installation.

So from the installer cd I went to Disk Utilities and confirmed that the Mac HD was gone and Windows partition from bootcamp might've went over it and wiped it.And I cant even use that windows partition that was called "disk0" cause apparently is was formatted incorrectly.

I cant create a new partition on disk utilities either cause the important buttons like partion drive, verify, repair, basically anything to format the original drive was grayed out.

What shall I do? I'm at an utter lost.

I tried resetting the PRAM, still no avail. I tried Single user mode but i get Gray screen of death.

The Macintosh HD partition got replaced with the Windows NTFS Partition named 'disk0' and didnt even format properly.

on Disk Utilities from the installation CD i pressed info button on it and it reads:

Name: disk0
Type: Volume

Disk Identifier: disk 0
Mount Point: /Volumes/Untitles
File System: Windows NT File System (NTFS)
Device Tree: /PCI0/SATA@1F,2/PRT0@0/PMP@0/@0:0
Writable: No
Capacity: 186.3 GB (200,049,647,616 Bytes)
Free Space: 127.5 GB (136,904,531,968 Bytes)
Used: 509.7 MB (534,417,408 Bytes)
Number of File: 3,050
Number of Folders: 0
Owners Enabled: No
Can Turn Owners Off: No
Can Be Formatted: No
Bootable: No
Supports Journaling: No
Journaled: No
Disk Number: 0
Partition Numer: 1


Main Macbook Pro Harddrive:

Name: FUJITSU MHY2200BH Media
Type: Disk

Partition Map Scheme: Unformatted
Disk Identifier: Disk 0
Media Type: FUJITSU MHY2200BH Media
Media Type Generic
Connection Bus: Serial ATA 2
Device Tree: /PCI0/SATA@1F,2/PRT0@0/PMP@0/@0:0
Locked: Yes
Writable: No
Ejectable: No
Mac OS 9 Drivers Installed: No
Location: Internal
Total Capacity: 186.3 GB (200,049,647,616 Bytes)
Free Space: 127.5 GB (136,904,531,968 Bytes)
S.M.A.R.T. Status: Verified
Disk Number: 0
Partition Number: 0

It seems it says Locked and unwritable, could that be why i couldn't partition it?

I've given as much info as I could, I hope you can help to save me a trip to the apple store. Thanks!
 

vshard

Registered
Hi, I don't know if you solved this or if your situation is quite the same. It sounds similar to mine (tried to install windows with bootcamp, overwrote whole hard drive instead of dynamic partition, tried to format (as ntfs) and install osx only to find there were no drives to choose...)

Here's how I fixed that... booted from the windows install disk and deleted the partition (so you have unpartitioned space) then booted from the mac install disk and created a new partition in disk utility.. and boom... I have options, it shows up, I can install.

Apologies for the rushed post, but I've been working at this for hours and finally got a break - I'm excited!
 
Top