Cant repair osx partition using DFA


when i run disk first aid it tells me that the os x partition has problems , about 4 or 5 diferent things, but then tells me to repair them , but it never allows me to click on the repair button, it never lights up :( this sucks ass dont tell me were back to the old way of having to boot to anothe partition or boot to the cd to repair the stupid drive , btw i never knew mac users were such unix gurus, it seems like every since os x came out , everyone knows unix
I am having this same problem. DFA in OS-X tells me I have several problems with the OS-X partition. The repair button is disabled, however, because the program can't repair the partition used to boot the system.

So I booted to OS 9.1, but DFA in OS 9.1 told me the partition is fine and has no errors. I then ran the copy of DFA on the OS-X install CD-ROM. It also said that the partition had no errors. That's 2 out of 3 saying that there is nothing wrong with the partition so I guess I'll believe its okay. Its still an unsettling experience.
I had the same problem and DFA in OS X was finding many problems but could not fix them. I booted my system from my OS 9.04 partition, not the 9.1 that is on the OS X partition, ran DFA from there, fixed the problems, booted back into OS X and the errors were gone. I also booted my system from Norton Utilities 6.0 CD and that applictaion found errors that DFA did not. I fixed them, and booted into OS X fine. So for me, Norton Utilities when booted from the CD, worked for me. I have heard not to use it but Symantec's web page said it works fine when you boot from the CD. Anyway, DFA from OS 9.04 and Norton Utilities 6.0 fixed my problems. My drive in my PowerBook was getting noisy and would intermittently have noises coming from it. Since the DFA and Norton, it sounds OK again.


there is a way around this. either start up off the OSX cd and run disk first aid or start up the computer holding apple+s and when the text stops scrolling type in fsck and hit return. its disk first aid just not under the interface. if there is problems it will tell you and fix them. run this till you get a no probelms found message.

hope this helps.