dns lookup not working on 10.0.4


for some reason I can't get any dns lookups on my iMac. I've tried rebooting osx but it does the same. everything fine in 9.1, and it's not a network issue.

I've had this happen in 9 and before, and deleting the tcp/ip prefs usually fixed that. Is there a similar procedure for osx?

It is just dns that has stopped, if I type in an ip address, it works fine.
Check your network settings... make sure your have the correct number typed in the DNS field.

If you are using DHCP to get all of the numbers, and are using a cable/DSL router, then reset the router and restart your computer (this happens to me about once a month).

If you are using DHCP without a router, but through a Cable/DSL modem, try turning off the modem and letting it reboot.

Other than that, I don't know...
It was originally a static ip address. I've tried this address on another machine with exactly the same settings and it works fine. I've changed the address to another, and also tried dhcp from an win2k server with exactly the same results.

Disabling the modem eiuther by just turning it off, or removing it altogether made no difference.
Go to the terminal and type <font color="#0000ff">nslookup</font>. You'll get two lines immediate that say Default Server: and Address. Look and see if they're correct. If not, and you have it set right in the prefs, then something is definitely whacked somewhere.

Oh yeah, type exit to quit nslookup. :D
The server displayed is

Doesn't that mean obtain from dhcp? It displays that whether i'm using a completely static config, or gettng everything from dhcp.
No, it <i>should</i> display the current DNS server you are using. The system should already have gained that info, so nslookup should be displaying it fine.

If you go into the terminal again, and type <font color="#0000ff">file /etc/resolv.conf</font> does it tell you it's a symbolic link to /var/run/resolv.conf or a broken symbolic link? It shouldn't say the second one. If it does, your system isn't getting the DNS server. This is the file that NetInfo (or actually, lookupd) looks at to get your DNS server.
so far, im having the same exact problem as Bookem

nslookup shows

file /etc/resolv.conf shows:

/etc/resolv.conf: ASCII text

any idea why the DNS server isnt being pulled by DHCP?
/etc/resolv.conf pointed to /var/run/resolv.conf

first, i backed up /ect/resolv.conf just in case i messed up...
then edited /etc/resolv.conf to look like this....

domain blah.blah.blah
nameserver blah.blah.blah.blah

i grabbed the DNS server name from my laptop and put it in the /etc/resolv.conf

DNS now works fine, although I cant say that DHCP is pulling the DNS address anymore. Hopefully my ISP doesnt change DNS server names on me soon

DNS servers don't usually change....I was gonna suggest that one next if nothing else works. Got there before me! :p

Just know that /etc/resolv.conf gets deleted whenever you go offline - like when you reboot - so you'll have to edit again whenever that happens. Or you could make a little shell script to do it for you.

Err...make sure that you <b>NEVER</b> create the /etc/resolv.conf file when you are offline! Your system will probably freeze when lookupd tries to query the DNS server that doesn't exist anymore. (found this one out the hard way)