Garageband Unexpectedly Quitting

Lord Maelstrom

Everytime I try to open Garageband, it unexpectedly quits during the initiation phase. Even after I close the error window, the initializing bar remains visible and the GB icon in the dock seems to look as though it were still open.
The problem began after I had downloaded the Reason 3.0 demo and the WireTap Pro demo. Maybe thise has something to do with it.

This is the exact same problem I had with Internet Explorer awhile back, which was solved here:
Mr. K told me to move a file to the desktop (which didn't work at first, until I realized that there was another file to be dragged out there to).

I tried the same thing with Garageband preferences, but it didn't work. I figured that I'm probably making some mistake (like not dragging out another file).

Any solutions?
What files should I be dragging out from the preferences folder?
Any help is appreciated.


Lord, I had the exact same problem. I just solved it by deleting a file called, "tcua.component".

It was located in my user library> audio> plug-ins> components> tcua.component.

Not sure what the tcua plug-in was for. It must have migrated over from my old machine. I used to have a copy of Peak on my old computer... maybe it came from there.