I was so stupid to play with TechTool....

A friend of mine had a copy of TechTool Pro 2. He had left this on my external Firewire HD when he borred it for backup while installing Mac OS X. I was finally getting around to cleaning out that pesky drive, and I had never really seen the thing in action before, and I was curious. So last night I opened it up and started to play with it: big mistake. I never really tried to find out what it meant by Rebuild the drive in the various disk drive utilities it offers, I just sort of assumed it meant defragment, which I keep hearing is a great thing to do to speed up OS X. I can't find any free way to defragment my disk, so I figured I would use this. So while I was in 9.2.1 on the external drive, I Rebuilt the internal drive---with my Mac OS X install on it!!!!
So anyway, it gives me this weird report about minor inconsistencies, and I figure it's just fixin' stuff, so I go ahead. Next time I boot into X, all seems fine....until I try to Log in. PandoCalendar loaded fine, but nothing else did! Rainbow spinner and a desktop calendar, that's all I could get! no Finder, no Dock, no menu bar at first (got one after I force-quit the finder which apparently WAS trying to load, but the menubar recieved no menus)no desktop pic of my GF, nada, just a cute calendar and a spinning rainbow pointer. If anyone out there has any Idea how I might fix this (other than reinstalling OS X, some of the stuff I put in I don't think I can replace) PLEASE tell me or em@il me at rac234@psu.edu
Thank You
Yeah, try booting into single user mode, and creating another user. Perhaps the user you loged in has some probs, but another user's account (a new one) wouldn't exibit the same probs.

If you have another user account, try that one. And, in single user mode, try wiping the preferences of your user (after mounting the disks in read-write mode, of course).
I know it is not the user, because i tried logging in as root and the same thing happened. Don't get mad at me for not knowing this (i've had and used OS X all summer and didn't once need this info) but How do I go into single user mode, and what does fsck do?
Thank you for responding soon. As soon as i get an answer to that first question, I'll try fsck, and if that doesn't work I'll have to see if I can hold out and use 9.2.1 until 10.1 comes out, and maybe installing that will help. I just hope I can preserve my users...I use the machine a great deal, but so does my sister, and occasionally my mom. My biggest concern is that I need to be able to retrieve my mac.com em@il, and I don't know how to set that up in Eudora. I'm sure I can figure it out, I set my psu.edu mail up in that a dozen or so times.
Not a problem (you shouldn't have to know how to do this normally). Restart you system booting to Mac OS X, after the chime, hold down the Apple and "s" keys.

Apple techs use a different version of TechTool than the general public (it was made special for Apple) called TechTool Deluxe. I've never actually seen TechTool Pro so I'm not sure what the differences are, but Apple has a large section of their training course devoted to understanding and using this utility. In fact they advise against using Norton while servicing systems (though I keep a copy with me just in case).
Thank you RacerX, I will use that when I get home tonight (I am a student @ Penn State Abington, so I live @ home).
And thank you testuser, for reassuring me I should be able to keep my users.
Also, RacerX, I think the problem I ran into was mostly that a)I still don't know exactly what Techtool Promeant by the word "Rebuild" in reference to the drive and b) I was using version 2.0 when the program is up to 3.0.4 AND is now built for use in/with Mac OS X. I was a complete idiot, I should have known better, and I will be careful in the future.

As a completely off-topic statement, does anyone know if Apple will be opening a retail store near Philadelphia,PA? I will probably start a thread like this elsewhere, but as the question is heavy on my brain I thought I might ask here and now. Again, thanks for everyon's help, I'll post here the results of it all, hopefully sometime tomorrow.
NEVER use disk utilities on OS X unless you KNOW they are OS X compliant. Many of the OS 9 utilities do stuff that OS X doesn't like... for instance, Norton Utilities likes to rename files that start with a period so that they don't cause potential driver conflicts... in OS X there are TONS of files that start with a period, and they all need to do so. Issuing a 'fix' with Norton Utilities would make you have to reinstall OS X.

The only OS X compliant utilities I know of is Drive 10 (for sure) and the latest version of TechTool _3_ (I think, but don't quote me on this). TechTool 3 will still only run in OS 9, but it doesn't do any fatal modifications to OS X.

Until Norton or DiskWarrior are native on OS X, I would recommend not using them on your OS X drive.
Until Norton or DiskWarrior are native on OS X, I would recommend not using them on your OS X drive.

Actually, DiskWarrior seems to work just fine on an OS X drive.... I wouldn't run it in OS X, but if you boot from an OS 9 drive (or the CD), it works fine. In fact, it has already saved my drive twice after various crashes rendered it unbootable...