Lost User Account Setting in OS X Tiger

jentex

Registered
When I first installled Tiger I was checking out how to set up different accounts for different users. I really had no need for this so we just use one account. Never had a problem til yesterday. I was messing around in the Core Services in the system folder. I double clicked on MirrorAgent but nothing seemed to happen. My computer was running slowly so I began closing un-needed apps. When I got to the mail it froze up. I tried to restart but got the message that "MirrorAgent" would not allow a restart. It instructed me to quit it but I saw nothing that even said it was running. I did a hard shut down. When I logged back in on MY ACCOUNT all my settings were gone. There was a generic dock. No desktop pic, no bookmarks, nothing. When I double click my mail it prompts me to set it up. I am afraid that if I do this it will delete all the folders (extremely organized) that I had set up. Has ANYONE ever heard of this. PLEASE PLEASE PLEASE HELP!
 

Giaguara

Chmod 760
Staff member
Mod
Core Services are better be left alone unless you know exactly what you are looking for there.
Mirror agent is the daemon dealing with sync.

Go to the hard drive, and Users folder. How many users do you see? Most often when all settings appear gone, there can be a new user, or the previous home folder name was changed. Would this be the case?
 

jentex

Registered
I'm going to send you a screen capture of what I'm looking at, because to tell you the truth I'm not really sure. I have not messed with the users since setting them up originally. At that time there were 3. I will surely not mess with them again. At least not before reading–A LOT!!!
 

Attachments

  • Picture 4.png
    Picture 4.png
    54.3 KB · Views: 12

Giaguara

Chmod 760
Staff member
Mod
Are you using davidtroy account now?
Jennifer account is locked...
And there are a few other oddities there. The windows path on many files, davidtroy\something...
And some of the accounts having a capital letter in the account name.

Would this look familiar? Mac OS X 10.3, 10.4 or later: Return to default desktop, apparent "loss" of home directory
http://docs.info.apple.com/article.html?artnum=107854
 

jentex

Registered
davidroy has always shown up because I was unable to change the "short name" when we got this computer. It's not really a problem and has worked fine for a few years now. I have done something today or yesterday that has something to do with the damn mirror agent. We all use jennifer and the computer is always on so we don't ever have to log on. The only reason the other User Accounts are even on their is for learning purposes on OS X. I just wanted to know how to set up and use (they've been there and unused for about 3 yrs now). So jennifer is the main account. does it need to be unlocked?

And there are a few other oddities there. The windows path on many files, davidtroy\something...
And some of the accounts having a capital letter in the account name.

How would the paths have been created? They look strange to me too and something I haven't noticed in the past. Should everthing be in l/c? Needless to say I'm not a technical person but a graphic artist but really do need to get to the bottom of this. I can't even use my email w/o going remotely. Thanks for your help. Thanks for the article.
 

jentex

Registered
i'm back,
I now have 4 User Accounts. Jan Phil Jen Other. I'm really not sure how the OTHER got there. When I log in OTHER I use my name (in the top field) and password (There are two fields in the OTHER user. When I log in using Jen my user name is already there so I just type in my password. When I use the OTHER ACCOUNT to log in before it logs in, just for a flash it shows my original account and the flower that I used as an icon when I created the account. Also when I log in w/jan/phil the home contains DESKTOP, DOCUMENTS, LIBRARY, MOVIES, MUSIC, PICTURES, PUBLIC AND SITES. The two accounts that I seem to have screwed up include only the DESKTOP and LIBRARY. At this point I have to check mail remotely since when I click on my icon in the dock it wants me to set up the whole mail protocols again. Also, do you know, or know of anyone who could explain the paths (for davidroy) that seem to be just randomly placed in the user? Thanks for the info and links so far.
 

KellanApple

Registered
Hi there!

I work for apple and I had the same issue yesterday.

Do a spotlight search for a document or other file that you are 100% sure of the file name.


Found the files under library/documentation/userguidesinformation/users

it looks like it was moved from the home folder to here

This is a bug that is fixed by leopard.

Hope this helps!

-Kellan
 
Top