Mac OS X 10.0 weirdness


I just experienced my second disaster with OS X. The first time the Finder had a weird hang up, when I inserted an MO in the internal MO drive and OS X recognized it and tried to format it. After waiting a minute I decided to force relaunch the Finder. What happened next was that all applications showed up as folders (which they actually are, the application bundles are nothing but special folders with a bundle bit set that contain the app, resources etc.).

Somehow OS X must have forgotten about that trick and all I got was plain folders. I first thought, well the disk utility might fix this, but I soon learned that of course the disk utility, too, had turned into a folder. Even system preferences etc. Looking into those folders revealed nothing launcheable, so I tried to restart and boot into single user mode. After all the good old fsck wouldn't let me down, would it?

It appears Apple in their wisdom have somehow disabled booting into single user mode (at least holding down 's' on boot doesn't work--which was the method in the PB). So finally I booted from the installer CD (after all they didn't remove that functionality!) and ran the disk utility. Nothing. I ran Norton 6.0 (which is said to be able to fix OS X volumes), nothing.

Well, here I am with a hosed install of OS X, I decided to reinstall the whole system (argh! I feel like a Windows user!) and guess what, yes the same disaster has just happened again, with the only difference that this time all I did was log out!

This is ridiculous. OS X if far far from being anything but beta and Apple starts to look really stupid with bugs of that magnitude in a 'final' product. Apart from that even on my 500MHz G4 everything is ridiculously slow. If that's the future of the Mac, it might have no future...
I agree. This is nuts. Counting me, your the third person I've read about on this list with that problem. Let me know if you fix this. I'm going to call Apple about it on Monday.

good luck with os x.

PS: I've got a beige power mac rev. a G3 with 128 megs of ram, 266mhz processor, 1 video card (plus onboard), extra network card, firewire/usb combo card, and a 40 gig ata hard disk with os9, yellow dog linux, and, of ofcourse, mac os x retail version.
Well, that proves its not my wierd hard ware - your pretty stock compared to me.

Mac OS X is full of bugs, and is slower than the beta. And, on the top of that, they didn't build in support for old macs, so I had to download a hack to install it on my Powermac 8600 (400 MHz G3, 224 MB RAM). That is too bad.