MacOS X CD won't boot on iBook



just tried to install the public beta on my iBook (300MHz, 160MB RAM,
one 3GB partition with only a Swedish MacOS 9.0.4 on it) but it wont
boot at all. Either it comes to happy mac icon with the small CD icon
spinning in the upper left corner and there it stops. Or sometimes I get
a message after that saying things like " panic on cpu 0", "waiting for
remote debugger" among corresponding error codes. What could be wrong


Mans Langert

Well, I did update the hd driver to 9.0.4 level but it doesn't help. Why would I want to remove MacOS 9.0.4?

If you take a peek at the documentation that comes with OS X Public Beta (it can also be found on Apple's OS X support page), OS X Public Beta requires English, German or French Mac OS 9.0.4, with support for Japanese coming shortly. You have Swedish. It is not supported and Apple has already said that your setup won't work.

People could save themselves quite a bit of time, effort, frustration, etc. if they would just take the time to read those files labeled "Read Me."...
Of course I've read the "files labeled 'Readme'". More than once. The issue here isn't my MacOS 9.0.4 and whether it's international english, swedish, bulgarian or whatever. That's for running classic. I know swedish isn't supported for running classic yet, and I know there's a walkaround to make it work anyway. I've been trying for the last 2 weeks or so to install MacOS X Public Beta on my iBook, which meets the system requirements,with or without MacOS 9.0.4. That's my problem.
Sorry... I was in a bad mood...

Have you tried installing onto your iBook without the presence of MacOS 9 at all? Perhaps the mere presence of Swedish 9 on the same disk still causes problems.

Also, I assume you have the latest firmware update installed...

It runs like a champ on my iBook SE (first ed.)!
My last try was after installing the iBook firmware update 2.4 (though documentation says international english or American english version of MacOS 9 is needed, the update went fine) I reinitialized the hd with the DriveSetup on the MacOS X install CD. Then I again ran the installer, the damned machine rebooted, trying to do it from the CD and then I'm stuck again with the spinning CD icon. Arrghhh!!

Someone told me to reboot into Open Firmware (cmd-alt-O-F) and from there reset the PRAM (it should be "stronger" than doing it the ordinary way?). Anybody knows how to perform this operation? Browsed through the TIL (at Apples developer site) but it wasn't too easy to find.
Soon I give up.....

I noticed that with my Bronze Keyboard Lombard that the only time I got X to install was when I was running with ONLY the STOCK 64MB of RAM installed. After I removed my extra 128 in the top slot I haven't frozen since. X will Run under 64MB of RAM, albeit slow when switching between 3 or 4 apps, but it will run solid.
X is now installed and running! Even classic!
I'm not sure exactly wat did the trick, I mean I think I've tried just about everything. But I guess it might have been the removal of the 128MB RAM module, putting in a 64MB instead, or the conjuction between resetting PRAM from Open Firmware, installing the Ibook firmware upgrade (wich I did even if I didn't meet the software requirements) and copying the OS X installation CD from a PC. Anyway, after a couple of weeks trying to squeeze the damn thing in, it's there!
And it's running like a breeze, even on my 96MB RAM. It could be faster though, hopefully it's mainly because of the