No Classic with international OS 9


I installed OS X yesterday and everything is fine exept for Classic.
It will not launch since:

"There are no localized Classic-specific resources to update the system folder on Frank [my main partition]. Please select entother startup disk."

Now, then. What could be the problem? I'm not sure, but here's one possibility:

When opening the inspector (you know, old "Get info") for the Classic app there is, under "application" (I belive) a list of "localized resources". Aha! These are languages. Aha! And my OS 9 is the swedish version. And swedish is not on the list. Thus I conclude: Classic will not run any OS 9 - only English, German, French and Spanish (I belive those were the languages in localized resources). I cannot confirm this, but it seems plausible.

Beige G3 300 AV
128 Mb RAM
8 Gb HD
Swedish OS 9
You are right, but there is a work-around. I had the same problem, but am now writing this in OS X / Netscape with "Swedish" Classic. While I cannot say it will always work, do this to update the swedish System 9.0.4 to Classic:

1. Login as root

2. Locate the Classic app. It is located at:

3. Make a backup copy of Classic, but work on original

4. Show the Package Contents by ctrl-clicking the Classic

5. Go to Contents/Resources/

6. Option-drag English.lproj to make a copy

7. Rename the copy to Swedish.lproj

8. Close the package browsing window

9. Open a Terminal window and do:
cd /Applications/
ls -l TruBlueEnvironment

10. Change the privileges of this file:
chmod a+s TruBlueEnvironment

11. Close Terminal and Double-click Classic. Now the "normal" installation of the extra files will begin and Classic be launched. Probably you have to read some english afterwards, but I have found no trouble with installing the english resources onto my swedish system.

/Andreas, Ibrium HB
The work-around should not be needed for Dutch, English, French, German, Italian, Japanese, or Spanish systems.

Except that I'm not allowed to chmod TruBlueEnvironment (which seems to have no effect on the final result), it works fine on Danish system too (9.0.4 on G4) - having of course changed Swedish.lproj to Danish.lproj.

Thanks for helping!

When I made a Swedish version of the file Os9 started but apps are just started in the Doc (The Icon apears) but I can nut use the application. It is the same with al apps.

Please explain the operations needed in teh terminal window, wich I could not get to work, ?
I dont know how to change the privilegies in the privilegies window, as of /Andreas, Ibrium:s explanation above.

[ #10 : 10. Change the privileges of this file:
chmod a+s TruBlueEnvironment]

Anyone that can assist?

Best regards

Originally posted by Andreas90
I dont know how to change the privilegies in the privilegies window, as of /Andreas, Ibrium:s explanation above.

[ #10 : 10. Change the privileges of this file:
chmod a+s TruBlueEnvironment]

Anyone that can assist?

i did it by just typing chmod a+s TruBlueEnvironment
at the prompt when i got to that dir
>Please explain the operations needed...

Some comments for the interested, and in case of trouble:

1. To log in as root, use "root" (without the "") as login name. The root password is the same as for the first user account, unless changed.
Logging in as root is important to preserve access rights etc. of the backup file and to be able to perform the other steps properly. While an administrator account may do for steps 3 and 6, it is (I think) insufficient for step 10.

9. The first command, "cd /Applications/", moves you to the Resources directory in which the file TruBlueEnvironment (the real Classic / blue box program) resides. The Resources directory is actually inside the Classic app program bundle. cd = change directory.
The ls command is not needed, but lists the file in a way to show its properties. "ls" shows files in the current directory. If the command cannot be performed, chances are that you are in the wrong directory. If you have problems with step 10, the result of "ls -l TruBlueEnvironment" is useful for understanding why.

10. The command "chmod a+s TruBlueEnvironment" is needed to allow any user to run Classic. It makes the user id to be set on execution. That is, if you run as a simple user, Classic will not have the ability to do root stuff, like modifying the OS X system.

Some final remarks:

- Do not modify the copy of Classic, but the original. The original app will be launched when Classic is launched automatically (by double-clicking a file, at startup etc.). If the original is unmodified it will again yield the "no localized resources..." error message when launched.

- Steps 9 and 10 should not be needed if modifying the original, but are needed if the "copy" is used by some reason, since the set-id-on-execution flag is removed when the file is being copied.

- Try to copy the commands into the Terminal if you cannot get them to work otherwise.

/Andreas Rydh, Ibrium HB
This worked fine for me and I am in the Swedish classic Environment. But I have one problem. Can´t print from Classic!
When printig I get the nomal MacOS9 dialog with LaserWriter8 and everything seems OK, but with no result in my LaserWriter.
I can find my printing dokuments in the folder PrintMonitor Dokuments, restart in Mac OS9 and drag them to the desktop printer to print..
Does printing work for you?
>Can´t print from Classic!

Turn off the background printing in the Print... dialog. Then it should work without problems (=does for me).

Didn't get it to work, but maybe that's because I want use Swedish 9.2 as my Classic. The directories aren't on the same locations as in your post. But maybe that's because I have Classic on a different partition.
Any ideas?

iBook Dual USB 500MHz, OSX.1
hmm. I have this exact problem, and tried to follow these instructions. however. i do have OS 9.2.2 as my Classic startup, and i couldn't find the directory /Applications/Classic. Instead i found an application called Classic Startup in the following place: /System/Library/CoreServices/Classic Startup, which seemed to be the equivalent on my computer. I then started following the steps, without problems until step #9. When trying the command cd /System/Library/CoreServices/Classic i got the message "too many arguments". I then tried to take "smaller steps" by going first to /System/Library/CoreServices/, and after that to /Classic, but with the same result...
Would anyone care to translate the original instructions so that they fit my conditions?
I have had your exact same problem. I was able to get to /Resources/ by getting first to /CoreServices/ and then send the command

cd "Classic"

(exactly as written). I think it was the space 's fault. After that, navigating to TruBlueEnvironment was no problem.

P.S. I am a near-total UNIX ignoramus, so I hope this wasn't wrong in some way. If it was, please tell me. All I know is that it worked fine and I can now run Classic.

Thanks to arydh for the solution to this problem.

thank you for the tip. it worked. unfortunately to no use, since my end result of the whole operation still was zero. i still get the message about "no localized Classic-specific resources"... *sigh*