Photoshop CS3 problems again...


woke up this morning to find that my Photoshop CS3 and Illustrator CS2 were not launching on my older G5 tower running on OSX 10.4.11

I've got new equipment with newer versions of same programs but I like to run multiple tasks on my older G5

I've had this problem before - earlier this year, adobe issued an update that effectively shut down all of my adobe programs from use over a one week period - I was not alone - I found that many of my colleagues on similar platforms and versions of OS were having the same issues

I found a fix somewhere at the fix it place in the adobe triangle... and things have been fine up until this morning - I can't find any reference to this specific issue at adobe or anywhere else that is relevant within the past year or so

And for general reference, I haven't downloaded, installed or tampered with my system in a while and everything else works fine - I've used disc utility to check and recheck things

Is anyone else experiencing the same issues today or this past week and has anyone found a magic fix?

greatly appreciative of any help

John - a newbie here



Is your problem just that PSCS3 and AICS2 are not launching? What's happening when you launch them? Any pop-up warnings or errors?


update: so I tried to "uninstall" the Photoshop CS3 from my cpu this evening - no such luck - I followed the directions in my kit that came with the program and attempted to remove PhotoShop by using the "Add or Remove Adobe Photoshop CS3" in the Adobe Installers folder as instructed - nothing happens

I'm stuck and unable to remove or reinstall the program from my discs

I know this is an old program and an old computer but... its been working perfectly until this morning - what gives?

will I need to throw my perfectly good cpu away because I can no longer use PhotoShop or Illustrator on this cpu? and I can't install new versions that I've purchased for my other computers? seems like such a waste to me

very frustrated and loosing valuable time

kind of a plea for help and a statement at the same time :)


thanks for your help Natobasso

yes, I always verify and repair permissions first before doing anything else

I downloaded the AppleSMBIOS.kext file at the above link and followed directions to put it in the appropriate folder - did my repairs and restarted the cpu

I'm afraid that nothing has changed and photoshop, illustrator, (adobe programs) fail to remain open when launched just as before

My last resort will be to call Adobe today and get them to help me out if they can. I'm always told the same thing by them which is... I need to upgrade my programs... and I always tell them that I have the latest versions running on other equipment and they always tell me I should use the new versions... and I always tell them that its a waste to keep spending money on things that go out of date so easily.

And I know that all of my students and many colleagues and significant business owners agree especially these days when students, small companies (large too) and everyone else, seem to be on a fixed budget and restricted funds.

Again, thanks for your help Natobasso - I'll report back with any changes.


Tech-Bot 5000
Find the .pref and .plist files for the CS apps in question and move them to the trash. Then restart the apps, this will force them to recreate those pref and plist files. They should then work fine.


Hello and thanks again for the advice

I tried your suggestion and neither PhotoShop or Illustrator launch and stay open.
I typically will do the plist trick on those rare occasions when my system is slow so I do know the process.

And, I still can't "uninstall" - :(

I remain stumped by this problem since each and every machine I own uses its own proprietary copy of the programs. If the problem were system-wide, I wouldn't be able to use the programs on any of the machines. The problem is isolated to this generation of G5 powermac with the OS of 10.4.11

I will access files through my network and see if I can work from another computer - maybe that will work until I move this perfectly good machine into the nearby cow pasture.

thanks again for your help Matobasso


I've solved my problem - ! Its taken me almost one month but I finally enlisted the help of my mac tech person who did a major overhaul of my computer - he did a great job and all is fine now - we don't know the cause of the problem but at least it was fixable

thanks for reading and helping on this