Problems with Samba

danielj

Registered
I have problems with samba on the new Jaguar.

If I want to connect from the mac to a pc, I can see in the list all connected pcs. But as soon as I try to connect, I always get the message:

Connecting to smb://....

An error has occured (-5000)

I don't knwo why?

And on the other side, when I try to connect from a pc to the mac. I get to the login but I can't login. I tried first to reset the password on the mac, by changing it with passwd (I saw this tip in an other forum). But that didn't help.

Any ideas?

Thanx
 

jabhome

Registered
No matter what I tried I could not get my PC to connect to my Mac. I was able to connect via SMB to the Win box, but PC > Mac was a no go. It was not until I created a Account in System Preferences with a shortname the same as my Win Box that I was able to see the Mac from the PC.

My box at work was called jbarrios. I added a user with that name in the Accounts Preference Panel. When I attempted to connect to the Mac, the login appeared and asked for a password. The password that I used when I created the new account worked just fine. Until I created the new account no matter how many times I entered my Administrator Password the PC could not see the Mac. Basically you should create a new user for each winbox you want to allow access to the Mac.

As far as connecting to the PC it should be as simple as smb://ip_computer name/share. My connection works with smb://jbarrios/mydocs or smb://192.168.1.101/mydocs. You do have to make sure the File sharing is enable on the Winbox and you will be asked for authentication which will require your Mac Admin password.

Hope that sheds some light on things.

J
 

danielj

Registered
Thank you, the connection from the PC to the MAC now works.

But I get still this error -5000 when I try to connect from the MAC to the PC.

J.
 

agriffiths100

Registered
I had the same problem mounting Windows shares from Jaguar, it seems the easy access to Windows servers Apple claimed isn't as easy as it could be.

I was able to mount the share by hand though, if the Windows box is called "dell" using the commands:

% mkdir /dell
% sudo mount_smbfs //dell/SharedDocs /dell

will mount the share in the directory /dell. You may need to include a username and password in the format described in the man page if the share is protected. To see a list of available shares use:

% smbclient -L dell

It's really quite annoying that shares can't be browsed or mounted from the Finder though. One of the main reasons I went to Jaguar is that I hoped this would work seamlessly. If anyone has any ideas how to get it working I'd love to know.

The same thing goes with printing to a Windows printer, I haven't spent much time working on that but it certainly isn't as simple as it could be. Why can't you just select a Windows printer from the "Print Center" instead of using smbspool?


As for why you can't see the Mac disks from a Windows box, make sure you use the short name of the account when logging in, and enable "Logging in from windows" in the "Accounts" preferences.

I hope that helps some.

Cheers,
--dag
 

danielj

Registered
Thanks dag, from the command line it works. But you are absolutely right, it is very boring that it does not work from the GUI.

cheers

J.
 

Jermsmingy

Registered
I haven't had a problem connecting to a pc from my mac, but I have had a problem connecting to my mac from a pc. I had to create another user, but then I can't share my files. It is very annoying. I think that this is going to be something that apples fixes in a small update.
 

IchiroBoston

Registered
I had the same problem (-5000)...etc

I guess a while back I installed DAVE on OS-X and even after uninstalling it there were still files in the OS. If you go to DAVE's website you can get a list of where all the files are located, I had to boot into 9 to remove everything.
Now all works well :)

Ichiro
 

fddi1

Registered
If you are upgrade to Jaguar from a previous version of OS X, you will have to reset your user password in order to allow the samba connection from a PC to a Mac. What I did was to change my password to something else, then changed it back. I'm guessing Jaguar is using a different password format than the previous versions.
 

ebalch

Registered
I've had no problems at all connecting to servers on a windows network as long as I'm directly connected to it (that is NOT via PPTP). The auto-discovery using "Connect To Server" in Jaguar works like a dream! I can see stuff that I can't even see from my Win2k box ;)

However, if I connect using PPTP... Well, let's just say that things don't seem to work as well. No browsing the network and I can't connect to any of the servers via Finder. I'm not sure if I drop to the command line. Haven't tried that yet. Timbuktu and MS Outlook seem to work fine though. I'm on the network but something is amiss.

Any ideas?
 

danielj

Registered
Indeed, I've installed Dave once. Now, after having removed all DAVA-files, everthing is working properly!

thank you all a lot

j
 

LordCoven

Registered
Not sure if anyone's still interested in this :) but I just had the problem of not being able to connect from win to mac via samba because I couldn't log in ... that's until I noticed that in the accounts preferences when I opened my default user that *right* at the bottom in the dialog there's an option called "Allow user to connect from Windows" which wasn't checked. Once I checked that, I was able to connect from my windows PC. :) Woohoo!

C

PS: It was greyed out at first - that's coz you have to enter your current password b4 you can make any changes (d'uh!)
 

tosk

Registered
1.) Make sure Windows File Sharing is turned on in System Preferences > File Sharing.

2.) Make sure that the Samba daemon and NetBIOS daemon are both running. To do this, open up a terminal window and type 'ps -aux'. Look for /usr/sbin/smbd and /usr/sbin/nmbd. You might not see nmbd. If they're not running, at the console type 'smbd -D' and 'nmbd -D'.

Also, something y'all might consider is editing your /etc/smb.conf file. If you do you might want to include these:

----CUT HERE----

[global]
netbios name = NetBIOS name here (computer name)
security = shares

----CUT HERE----

After doing this, you'll need to restart the Samba and NetBIOS daemons.

I've had the iBook that's on loan to me from school hooked to my network at home and I didn't have any problems sharing files PC->MAC or MAC->PC.

Just some food for thought...
 
Top