Quicktime not working in Safari


Powerbook G4 17" 1 GHz, System 10.4.8, Safari 2.0.4, Quicktime 7.1.5

Problem: after a crash (occurered while whatching a wmv sequence in Safari with Flip4Mac), I uninstalled Flip4Mac. Since then, no way to watch an mpg sequence through Quicktime in Safari - either I get the Quicktime logo with a question mark or Safari crashes.

I tried: reinstalling combo 10.4.8, Safari 2.0.4, Quicktime 7.1.5, creating a new user - no change.
I therefor think that there must be some "bad" files somewhere in the system, I checked the safari and finder crash logs, here's what they say:

Host Name: Mon-disque
Date/Time: 2008-05-22 18:56:57.179 +0200
OS Version: 10.4.8 (Build 8L127)
Report Version: 4

Command: Safari
Path: /Applications/Safari.app/Contents/MacOS/Safari
Parent: WindowServer [83]

Version: 2.0.4 (419.3)
Build Version: 1
Project Name: WebBrowser
Source Version: 4190300

PID: 340
Thread: Unknown

Link (dyld) error:

Symbol not found: _QTSecurityPolicyRelease
Referenced from: /System/Library/QuickTime/QuickTimeImporters.component/Contents/MacOS/QuickTimeImporters
Expected in: /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime

Can you translate..?
Any ideas? Is there a "clean and safe" way to entirely remove Quicktime for a clean install?

Many thanks in advance and best regards

Last edited:


For those who come across this:

the problem was solved by reinstalling Flip4Mac - when I had unistalled it, the uninstaller had removed vital elements of Quicktime... :confused::mad: