Rosetta doesn't work.

Sunnz

Who wants a stylus?
I had some PPC App worked some months ago, like StuffIt.

I don't use PPC Apps regularly, so I am not sure what is the precise time when it stopped working.

Today when I click on StuffIt, the Icon comes up in the Dock, and disappears instantly.

I downloaded the new one which is an Universal App, and that worked.

Adobe Acrobat Reader (PPC) had a similar problem. I did not bother to downloaded the Universal version though, if there is even one.

So it seems like a problem with Rosetta?

I also tried to use a driver for my scanner today, which is also PPC Only, and had similar problem - it just does not run.

The computer had some minor problems before I discovered the Rosetta problem. I had the repair permission, and had to boot up from the OS X CD to do a Disk Repair.

And Application Support folder under ~/Library was corrupted as well, when I try to ls it, it has a I/O Error. I can't even do sudo rm -rf ~/Library/Application\ Support/, I had to move it to the Trash then copy the old one from my back up. (Thank God I had backup the entire home directory just before the folder gets corrupted.)

So yes, it had problems before, but the Rosetta one I just don't know where to begin... :(
 

bogey

Registered
Hi Sunnz,

I just read your question from last year.
I have the same problem since last week on my MacBookPro, OS X 10.4.11. All rosetta emulated applications suddenly have stopped working. A short flash of the program symbols ist all I get when I try starting one of them. Before that, I noticed that I could not install the Security Update 2008-007 Intel, no matter if by software update or manually.

My question: Did you find a solution to reinstall or repair rosetta? Any help would be highly appreciated!
 

Sunnz

Who wants a stylus?
I never actually find out what the problem is, so the problem was still there and never fixed.

I kind of just ignore that problem for a while, and eventually I just got a new computer and I just haven't used any PPC programs after... I haven't seen that corrupted directory problem neither.

The only thing I can think of is to reinstall OS X and see if it fixes it.
 
Top