Slow Open/save File Dialog System Wide

chrisesp

Registered
Hi,

When ever I try to open or save a file in any application the spinning wheel is shown and the dialog takes from 5 to 20 seconds to display. Once it is on screen the speed returns to normal.

I have a G5 Power Mac 1.6 GHz (Single Processor) 2 GB RAM (crucial) 2 SATA hard-disks (original 80 GB used as a clone for the 160 GB - I use carbon copy cloner) Everything else is as standard with the Mac. This problem started with 10.3 and may have been at the same time as installing the second 160 GB hard-disk, cloning the original to the new one, then changing the SATA cables around to make the new hard-disk on bus A. I then upgraded to Tiger but the problem still persists. I have tried repairing permissions and have used support tools like cocktail etc to check for hard drive issues and clear the cache files.

Also, on installing the second hard-disk, I also tried swap cop to change the swap file to the backup hard-disk. This did not work so I manual modified the files to return them to the original state. I did this while the system was running 10.3. I take it on upgrading to 10.4, the swap file config would have been fixed anyway?

Everything else on the system seems fine. If nothing specific is found I may try removing the old hard disk.

Any help would be great
thanks for your time.

p.s. I am technical.

regards,
Chris
 

FredB7

Registered
Do you have an iDisk?

I had the same problem, everything in my system was fast except open/save dialogs.
Disabling "iDisk Syncing" solved it. (in "System Preferences", ".mac", "iDisk"). Took me months to figure it... Grrr.

Hope this helps...
 

simbalala

Registered
FredB7 said:
Do you have an iDisk?

I had the same problem, everything in my system was fast except open/save dialogs.
Disabling "iDisk Syncing" solved it. (in "System Preferences", ".mac", "iDisk"). Took me months to figure it... Grrr.

Hope this helps...

That seems to be common. Having an iDisk mounted may also cause problems with software updating.

You have to turn off syncing before you can dismount it. That took me a few minutes to figure out. Best to only mount it when you want it.
 

UpQuark77

Registered
I thought about this..and came up with this comprimise:

Under Finder preferences - sidebar - I unchecked the Idisk.

Poof..it worked.
 

mcneale

Registered
Every time I would save a new file from an app such as Pages, the dialog for saving would pause, I would hear the timemachine backup disk clunk and start up, and then I would get the dialog for where to save the files to etc. The trick of getting rid of the TimeMachine backup from the sidebar view worked perfectly as a way to accelerate all the "Save As" type dialogs.

Thank you, and I hope this helps others with slowdown problems due to TimeMachine and other external disks.
 
Top