SuperDrive DVD - Can\'t read or write


I've got a Power Macintosh G4/733 with a SuperDrive (PIONEER DVD-RW DVR-103, Rev 1.90), running Mac OS 10.3.9.

Ever since I replaced the hard drive about 3 months ago I haven't been able to burn DVDs. It ejects blank ones, and can't read some discs burned elsewhere. It can't be a disk speed issue, because I was able to burn before.

I've tried several suggestions from anyone, anywhere. It doesn't need Apple's SuperDrive update, or Patchburn. Also, I zapped the PRAM, and reset the Firmware. Neither worked.

Any help or suggestions will be GREATLY appreciated!

Are you using -R or +R DVD's? SuperDrive only recognizes -R, but will burn all other forms. The trick is to find a 3rd party burning software, like Toast Titanium. Use that to burn all your Cd's and Dvd's.

Good luck.
Are you using the ultrawide ata cable or a standard ide cable? I've heard of problems with the standard cable. Also, double check to make sure cables are connected securely (you knew that though).

I just bought a DVR-110D which wouldn't read cds at all but would play dvds. I sent it back on RMA. I'm hoping this isn't just a poor quality drive... because I've read tons of reports of these types of problems with these drives....
I'd a DVR-105 that eventually stoped reading almost ALL non-factory DVDs (ie; it only read data DVDs and rarely mounted movie DVDs). I replaced the sucker with a cheap (I shopped around–!) DVR-109BK awhile back and it reads everything— and still does.

I'm not sure if there was a dust problem or overheating problem or whatever but the replacement was well worth it...

Oh, and head over to to find firmware updates ;)