X11 Window forwarding - Remote Gnome session?

AkleyMac

Registered
Hello,

My university currently allows me to connect to their Linux servers with SSH, and to use graphical applications with X11 window forwarding (using the -X option at SSH login).

I was wandering if anyone knew how to start a remote Gnome session (not just the terminal in SSH, but using the GUI). I have got it to almost work by connecting with SSH and executing:

'gnome &'

I get the splash screen, and the toolbar appears at the bottom of the screen, but then the desktop moves between my two displays in such a way as to make it unusable - the toolbar disappears of the bottom along with half of the desktop, and I can't move the window.

I have read that Apple have used some strange display options with X11, but don't know how to change them. Any help would be much appreciated!

I am using OS X 10.5.6 on a MacBook Pro, with my desktop extended across two monitors (which I think may be why this doesn't work...).

Thanks in advance!
Tom
 

nixgeek

Mac of the SubGenius! :-)
You'd have to type "gnome-session" at the command prompt after you've SSHed in. If you're on your Mac, remember that you'd have to launch X11 first and use the xterm terminal to SSH to their GNU/Linux servers (at least that's how it's been up to 10.4, not sure yet about 10.5).

Also remember that it will probably be somewhat slow, especially if you're loading the entire GNOME desktop environment. I usually just launch specific apps that I need so as not to saturate the bandwidth available to me with something as large as GNOME.
 

AkleyMac

Registered
Hi nix,

Thanks for the reply - I just tried logging in with SSH and launching gone-session all from xterm, but it still seems to be doing something weird with the displays. I'm thinking this may be a problem with the X11 settings...
 

Mikuro

Crotchety UI Nitpicker
I've never managed to get this working well. I think (could be wrong) the main problem is that Gnome wants to use its own window manager, which it can't do remotely, since OS X's X11 is acting as the window manager. When I tried to launch a whole session, my keyboard input also became garbled.

I agree with nixgeek; it's best to launch just the apps you need. Start with gnome-panel and you'll get your familiar menu bar and task bar.

Most of the time, Nautilus (Gnome's file manager/desktop) doesn't seem to want to display a desktop, and the other half, it displays the desktop above every window instead of below (!). I have made this work on occasion, but I honestly don't know how. It's not reliable.

You'll probably want to use a file manager besides Nautilus, like Thunar, or use the --no-desktop option of nautilus.

I haven't tried this with any other DE yet. Maybe I'd have better luck with a lightweight DE like XFCE.
 

nixgeek

Mac of the SubGenius! :-)
It might have something to do with how GNOME is configured on those servers.

I just tried to SSH to my Slackware box from my iMac running Tiger (hence the delay in my post...see below :p), and I was able to launch KDE. When I tried to launch XFCE, I got a strange error stating that there might be a bug in this particular X11 session (the one from Tiger) preventing XFCE from launching. YMMV in terms of launching full-scale desktop environments through SSH port forwarding, but launching only the apps you need should work just fine.

...Oh, and what Mikuro said, too... :D
 

AkleyMac

Registered
Thanks for the replies!

As Mikuro suggested, I tried gnome-panel, which is pretty much what I needed (sorry, I'm not all that familiar with Linux yet, but like what I have seen so far :))

The start and task bar seem to work great in X11, so thanks! And I can launch apps fine, so I'm sorted. Thanks!
 

skara

Registered
I'm trying that stuff since a while. Especially the gnome-session.
The "gnome-panel"-stuff works great for me. Many thanks.
Last thing to do will be a nice bash/Apple-script automating the whole process.

greetz
skara
 
Top