1.0 Release Candidate 1: Bug Reporting

ScottW

Founder
Staff member
Please post bugs to the application or online interface for Help.app in this thread for version 1.0, RC1. Please provide as much information about the operating system version you are using, what type of system you have, etc. If you are able to post your system profile using Help.app, provide a link to your system profile.

Is the bug you are reporting repeatable? What steps do you go through to repeat the bug?

KNOWN BUGS in RC1:

Under Mac OS X 10.3.x with "Refresh Tickets" listing doesn't function correctly.

Under Mac OS X 10.3.x many users get a Applescript Error -10814 when running the "Start Remote Sharing" feature. A reported fix for us was to open a terminal window and run "sudo update_prebinding -root /" and wait for that to complete. You may need to reboot. This resolves this particular error in some cases.
 
I get this message every time i try to open it. but it never quits when i click on quit. the osxvnc is on-line and running. running tigar 10.4.2 768mb ram, 800MHz powerbook.
 

Attachments

ThGreenMoFo

Registered
I'm getting the same problem as tysonbarber. As bobw suggests, if you just click Upgrade, it works fine. No problems for me on 10.4.2
 

Cheryl

Rosie Moderator
Staff member
Mod
When you click on the link to www.macos.com (that is what it says) you get another page with the same language.
Scott:
Yea... I had a typo and left out the "x".

You folks are killing me here. :)

********

Obviously, because you deleted part of my post when you responded. :eek:
 

Boru

Registered
Seems to be working fine on my work G4 (OS X 10.3.9).
I had the upgrade window pop-up as well but hit "upgrade"
and all is well. I'm connected, published the profile, etc.
and no problems. ( I didn't post any questions though).
I'll test at home on the G5 with Tiger 10.4.2 ...

And Cheryl, I think that URL is just a typo ...
The "x" was left off of "macosx.com" . Which you've probably
already figured out :D

This app is so freakin' cool !!

Great job !!!

Best,
Brian

Edit: OK, I posted a question called "Testing", please ignore ...
but it works great !!
 

lushbudget

Registered
The app launches, Upgrade pops up, click it goes away. what's up w/VNC? I work behind a firewall and don't want to have to spend a lot of time configuring port maps,etc. Will we still be able to access the system the old fashioned way?

PS: Love the look and scale of the app! Not too big, and matches the rest of OS X's appearance. I'll be coming along for the ride to see where we go...
lb
 

ScottW

Founder
Staff member
lushbudget said:
The app launches, Upgrade pops up, click it goes away. what's up w/VNC? I work behind a firewall and don't want to have to spend a lot of time configuring port maps,etc. Will we still be able to access the system the old fashioned way?
Actually, if you read what the application does on the App page (with the type url) at http://www.macosx.com/apps/help.htm you will see that the primary purpose of Help's vnc remote integration is to bypass the need to setup up Port forwarding, configure osxvnc, etc.

What is the old fashion way?
 

ScottW

Founder
Staff member
The upgrade error is an error on my side. I had to go do some things and left it setup incorrectly on the server side. The unsupported version message should go away.
 

klumberg

Registered
Every time I try to launch screen sharing I get an Error: SSH Not Established. Service failed to Connect. Port Not Open. I'm behind a firewall on an airport network.
 

ScottW

Founder
Staff member
Ok. The application checks the our server to make sure the connection has been setup via SSH prior to confirming the connection. If it can't confirm it on the server side, it errors out with the error you got.

A couple of things could be happening, one of which is outbound SSH (port 22) is not allowed to the internet from your connection. If this is a home connection, this more than likely is NOT the issue.

I'd like to troubleshoot this issue with you in real time if possible. Contact me on IM at digitalcrowd and we can see what is going on. Also, provide what OS version you are on and what type of Internet connection you have.

Scott
 

samworthynl

Registered
Hey scott,

i'm having the same error as klumberg. i'm running 10.3.9 on a 1.25ghz emac, 512mb ram with a direct ethernet internet connection

other than that, everything seems ok.
sam
 

Squibler

Registered
I had a problem with the text box that you enter your question into, you can't 'enter' down a line, all it does is highlights the text you have written so far.
The actual posting of the message worked perfectly but the text inputting thing was what got me all frustrated.

Here are my specs:
Machine Name: iMac G5
Machine Model: PowerMac8,2
CPU Type: PowerPC G5 (3.0)
Number Of CPUs: 1
CPU Speed: 1.8 GHz
L2 Cache (per CPU): 512 KB
Memory: 512 MB
Bus Speed: 600 MHz
Boot ROM Version: 5.2.5f1
Serial Number: W852085ASDX
Operating System: Mac OSX 10.4.1

Keep up the good work,
-William
 

ScottW

Founder
Staff member
Thanks Squibler, I have already fixed this in the latest build (not online yet)...

Here is the current "done" list...

+ When quitting the application a active remote control session is disconnected
+ Changed body field format for the question form
+ Added a Copy to Clipboard feature for Remote Sharing settings
+ Added Three Test Buttons Under Settings for Troubleshooting Connections
- Internet/Account Test checks for port 80 connection and account verification
- SSH Test checks that the application can use SSH and that Port 22 is open for outbound connections
- Remote Test checks that OSXvnc is installed or in the case of 10.3 users, it defaults to look in the /Applications folder
- Added Connection Timeouts which caused the application lock up if not connected to the internet
 

av_man

Registered
Running 10.3.9 on a G4 iBook behind a university firewall, it fails the Internet & Account test "Failed port 80 blocked". As far as I know, the proxy only allows traffic on port 80, so I'm not sure about that. Probably a problem at my end.

Also, when I try to test remote sharing it gives me the error "Path OSXvnc is not defined". I've attached a screenshot of the error box. OSXvnc is definitely in my apps folder and definitely works because I use it all the time.

Anyway, everything else that doesn't work is because of our proxy. Overall I'd say it's a great app. I can't wait till I can use all the features :).
 

Attachments

ged3000

Registered
Its pretty minor, but in the application menu, the application is reffered to as 'Help.app' - should that just read Help?

(OS X 10.3.9)
 

JFG

Registered
Hello,

I discovered your service today and posted my first request with your good-looking Help.app. In the process I discovered a bug, so here is how to reproduce it.

My question (submitted on the site as #13145) contained the following paragraph:
"Secondly - I tried the "Slideshow" option from the Finder context menu (when you select one or more pictures). All I get is a black screen..."

Help.app displayed the following error:
AppleScript Error
sh: -c: line 14: syntax error near unexpected token '('
etc.

I figured there was a problem with double quotes or parentheses, so I submitted a test question that read:
"Hello"
Now, can the application send the above paragraph without error?

This worked and was submitted as question #13180 (closed within 2 minutes, that's impressive support performance!)

I changed the test phrase by omitting a quote:
"Hello
Now, can the application send the above paragraph without error?

Sure enough, the error came, a slightly different one:
AppleScript Error
curl: no URL specified!
curl: try 'curl --help' for more information
sh: line 2: Now,: command not found
etc.

What if I move the quote and add a parenthesis to the game?
Hello" (
Now, can the application send the above paragraph without error?

At that stage, the error revealed the underlying script syntax (see picture attached), which is a bad idea as it gives crackers an avenue to exploit.

So, before someone crafts a malevolent question, try to escape double-quotes in the question text before passing it to curl. Or better yet: don't use curl through a shell but call it from the handy Objective-C wrapper called CURLHandle, available from http://curlhandle.sourceforge.net/. Use the setPostDictionary method to populate your fields with user-provided text. Unbelievable as this may be, Apple does not provide an easy way to build a POST HTTP request in their WebKit or "URL Loading System" frameworks. If you need something more sophisticated, you can use OmniWeb's excellent OWF framework, available from http://www.omnigroup.com/developer/sourcecode/.

Hope this helps,

JFG
 
Top