10.0.4 --> 10.1 - Now Apache won't start


I was hoping that I could cheat and do an upgrade from my existing 10.0.4 to 10.1 without any issues, but it appears I was wrong.

Under 10.0.4 I did a few (what I though were minor) tweaks to the Apache httpd.conf file. Mostly I changed the Web server document root to my home directory (/Users/<user>/public_html/).

This all worked fin under 10.0.4, but now that I've upgraded to 10.1, the Sharing preferences panel is hung at "Web Sharing is starting up..."

1) Can someone remind me know to kill this?
2) How do I revert my httpd.conf so that it can start up?
You could try starting apache from a shell:

sudo apachectl start

This is how I came across the mod_hfs bit that broke with the devtools installed during the upgrade to 10.1. When you attempt to start this way, apachectl will usually say why it failed to come up.

Hope this helps...
you should have a file call "httpd.conf.default" rename this to "httpd.conf" . hopefully apache should work again. you will still need to make your adjustments (/Users//public_html/) but at least you will be able to tell what the problem is by making the changes one by one.
hope this helps...more importantly i hope it works:)
On many UNICES you can kill a start-up script with a cntrl-c, not sure about X.

As to apache, another useful trick is:
sudo apachectl configtest
which will look for problems in your httpd.conf.

I wonder also if the upgrade created a permissions problem; apachectl configtest will alert you to that as well.

I posted an article on this almost 2 weeks ago. I found the solution. I do not know what causes this but look up my past articles and you can see how I fixed it.

Originally posted by kenny
... the mod_hfs bit that broke with the devtools installed during the upgrade to 10.1...
[localhost:/Users/tbaker] root# apachectl start
dyld: /usr/sbin/httpd Undefined symbols:
/usr/sbin/apachectl start: httpd could not be started
[localhost:/Users/tbaker] root#
Yes, that is it.

As a short-term fix I just commented out the apple_hfs_module in the httpd.conf file and now it starts.

Next I'm going to try to find terran74's post with the long-term fix...