10.0.4 Update broke Citrix under Classic

sveijk

Registered
I was running The Citrix Client for MacOS 4.1 (build 36) under 10.0.3 Classic without problems. Since I upgraded to 10.0.4 (on three machines) the app runs normally, but it can't find the servers (IPs are in the preferences). Very strange. There may be somthing else going on here, but so far 10.0.4 is all Ihave found (the servers' admin swears they haven't changed anything).

I haven't tried the Java client yet.
 

Klink

Member
Hi sveijk,

I've been using the Mac Citrix Client version 6.0 (Build 96) for a while without any problems under X 10.0.4 Classic. Yes, even the video streams correctly now with this new build (took them 4 months to fix this from the v6.0 B66). The nice thing about updating to this version is that you can keep your old version document which has your specific settings. I would suggest trashing your Citrix preferences, the whole folder, regardless of upgrading or not.

Citrix Java Client - I've installed it for X and found it to be a bit cumbersome to initiate a connection. One has to cd to the Citrix directory via the Terminal, launch the executable via the Terminal(that you must make yourself), wait for the JVM to load (if it loads properly the first time), then manually enter in your client settings in the connection window (IP Address, caching, window params, colors, home directories, etc.), then finally click Run to start a connection. Not only is making a connection an ass grinder, but to have to basically make the application yourself. This is what I call poo poo.
All this ballyhoo seems a bit senseless. Takes computing back 20 years if you ask me. But we're talking about Citrix here, maker of software for all clients, master of none (hee hee). Well I might be a bit harsh on them but they do treat the Mac users like a step child.

 

sveijk

Registered
Hi Klink:

Thanks for the reply. My problem turned out to be my firewall rules. I must have changed them (on three machines!) and forgotten. The only other explanation would be that 10.0.4 changed them, and that ain't the case.

I'd be interested in knowing how you got Citrix 6.0 to work at all. I have never been able to get it working with all our published apps. Some apps are fine, others die with a type 2 error. I sat down with the server admin and went over it in detail, but we didn't find anything different about the implementations. Citrix was no help.

You could make a .app bundle out of the java client. I don't remember the details of the process, as I have not had occasion to do it. But I know you can. The Phex guys distribute an OSX bundled version of their java Gnutella client.
 

Klink

Member
It's great that you found your problem with your personal firewalls and pardon me if I insulted you with the newbie "delete your Citrix preferences" answer. I don't run into many knowledgeable Citrix users such as yourself.

Let me tell you a bit about the server I admin because the way it's implemented greatly affects how clients connect and interact with it.
It's a dual NIC dual proc Windows NT Terminal Server 4.0 SP6 with Citrix MetaFrame 1.8 installed on top. I run only one application (ScheduAll-a graphically visual scheduling database) for users. 98% of the users are Macintosh clients. I force clients to connect in "Initial Program" mode, which effectively disables them from having a Desktop. I also have the clients initiating a connection with the server's static IP address, there by forgoing the NT or Citrix Network Browser Services.

Something closer to your home - I have experimented (successfully) in the past in having users able to run multiple applications on the same connection(with an "Application Set" in Citrix terms) without bringing them to a full Desktop. I would set up my Application Set for say ScheduAll, NotePad and Calculator. The Application Set Manager will be configured to have all users access these applications. I would again have users initiate a connection in "Initial Program" mode, but instead of entering the target application path for one of the 3 applications, I would set the path to the Program Neighborhood exe (S:\WTSRV\system32\Ica PassThrough\pn.exe). So now a user would connect by direct IP address, have basically an empty Desktop with only the Program Neighborhood on screen so they can select which or all applications to run. They would disconnect once they exit the pn.exe.
All this finagling was my attempt at locking down the Desktop with clients that are not using the NT client connection application. As far as I could figure out, the only way to lock down Desktops was to use the Policy Manager for each user's or group's Desktop. Could never get it to work. I assumed it was because I was not using NT clients to connect to TermServ.
I hope this gets you closer to where you want to go.
Have you ever tried pulling your personal firewalls out of the picture when attempting using v6.0 B94? I remember seeing many posts on the Citrix bulletin about Admins and firewall settings when it comes to the Citrix Program Neighborhood and there UDP ports.

Thanks for the Phex tip. I'll check that out.
 
Top