10.1 broke Postfix! (and lots of other stuff)


ok, i got everything else working again except postfix. first time i launched pine, it gave an error that /var/mail needed to be 1755. so i did that. then tried to send an email. big fat error(sorry, don't remember what it was). so i went back to the stepwise article i followed originally when installing postfix and did these steps:

Postfix replaces /usr/sbin/sendmail with its own version. Instead of allowing the Postfix install to clobber our previous sendmail environment, we should move it aside and remove its setuid permissions.

sudo chmod a-s /usr/sbin/sendmail
sudo mv /usr/sbin/sendmail /usr/sbin/sendmail.OFF
sudo mv /usr/bin/newaliases /usr/bin/newaliases.OFF
sudo mv /usr/bin/mailq /usr/bin/mailq.OFF
sudo mv /usr/bin/rmail /usr/bin/rmail.OFF

Note that this step may not survive an operating system upgrade. Should Apple decide to upgrade its sendmail binary in the future, the SoftwareUpdate installer will clobber these changes. Make sure you understand what these steps have done, so that you may recreate them in the event of getting clobbered. After such an event, you will probably want to follow redoing the above steps with:

sudo ln -s /usr/local/bin/sendmail /usr/sbin/sendmail

We need to "turn off" the existing sendmail startup script. The easiest way to do this is to just modify the "Sendmail" startup script to exit immediately after being launched.

pushd /System/Library/StartupItems/Sendmail
sudo perl -i~ -pe 'print "exit 0\n" if ($. == 2)' Sendmail

Note that these last steps are somewhat fragile. If Apple should decide to upgrade this Sendmail startup script in the future, the SoftwareUpdate installer may clobber the change we just made. Make sure you understand what we just did so that you may recreate these changes in the event that Apple clobbers them. (just rerun the above 3 lines).

now, i am able to receive mail, but when i try to send mail i get "/usr/sbin/sendmail does not exist"

it does, but it's a link to /usr/local/bin/sendmail which does not exist.

now, correct me if i'm wrong: on the original install i moved the sendmail components aside, postfix put in replacements when it installed. those were overwritten by 10.1, i moved them aside again just as the article described. *but* i don't have the original postfix created components to move back right? so i have to reinstall postfix? but i can't do that yet since the 10.1 developer tools aren't downloadable untill next week.

if somebody who knows more than me sees anything incorrect with the above/a different fix please respond!

This gives me pause. I have Postfix running on 10.0.4 just now, and don't want to go back to sendmail. You say the dev tools are not included with the CD, or is this a downloaded copy?

Have your original compilers &amp; such been eaten by the upgrade - cc &amp; awk &amp; so forth?

Assuming you have no compilers, then you're probably just have to wait until you can get one.
nope, no developer tools with the cd. this is the "instant up to date" cd that i picked up at an apple store. dev cd does come with the 19.95 cd you order from apple.

i tried a reinstall of postfix but it failed during 'make'

guess i just have to wait untill the new dev tools are downloadable.
ok, 10.1 dev tools installed. postfixed recompiled and reinstalled.

mail being sent and received by Postfix seemingly without problems(no errors in mail.log, all test emails making it to/from my system)


now pine appears to have some issues. immediately after sending an email i get "Problem detected: 'Received abort signal'.
Pine Exiting.

from what's left in the terminal window it doesn't appear that it got to the point of writing to 'sent-mail'

directory permissions are all still set the same as the ever were. i can't seem to find pine.log or anything like that. ideas?
Longshot, but did you check /var/log/mail.log ?

FWIW you can get the Dev Tools FREE from Apple Developer Connection website. Just sign up for an acct.

I still use sendmail, but I'm on a single user system. But I am running the wu-imap server, fetchmail and procmail without a hitch.

Ok, I"m getting this error when i send mail in pine, it sends but still does this as soon as it does.

Problem detected: "Received Abort Signal".
Pine Exiting

The sent-mail folder is NOT written, but the mail is sent.

Any ideas on how to fix?
cmasters - no idea how to fix, I'm afraid.

pine dies when it runs other external programs too - for example, if I open a PGP encrypted/signed message, gnupg opens, successfully decrypts/checks the signature, but then I get the same error when gpg exits.

For whatever reason, it has no trouble with using an external editor - I use emacs as my mail editor in pine, and that works just fine.

I'm afraid I've had to go back to Mail.app (yuk!) for the time being...