10.1 GM Problems????

m1mx

Registered
I've been running 10.1 5G64 (so called GM) for a couple of days now and have found a few things that bother me about the so called GM...

1. I am not able to connect to a Windows network. What happen to built in Samba?

2. DVD Runs well but if I hit any other key beside "stop" or "Play" on the controller I get a "Not Permitted" error. So far I can't use the FastForward button without getting that error

3. Not able to burn CD's on my Yamaha SCSI CRW.

Other than those issues I'm very happy with everything else. But to completely make the switch I need to have access to a Windows network.

Hopfully something will change with the final release and all will be good:)

Computer info:
Power PC G4
memory: 512
 

Kazrog

Mac Metalhead
Thanks for that bit of info. Unfortunately, I work in a Windows office and this is important to me as well.
 

treybomb

Registered
SMB works just fine. It just doesn't work like it SHOULD. In order to access SMB shares on a PC, just goto Connect To and enter:

smb://xxx.xxx.xxx.xxx/share_name

It SHOULD automatically show you a list of shares, but if you know the share name on the machine you're trying to access, it works fine.

Hopefully they'll fix this in the near future.

- T
 

theCaptain

Member that enjoys Meece
Has anyone here tried the DAVE beta for OS X? It works brilliantly. I have yet to find one thing about it that bothers me.
 

Kazrog

Mac Metalhead
DAVE is great if you use only native OS X apps. However, Classic apps cannot see the mounted windows shares.

At my job, I have to use Photoshop to access files on Windows shares. All the time. That is why I am still running 9.2.1 at work, since obviously Dave for OS 9 works. But Dave for OS 9 cannot work in the Classic environment in OS X. Sharity also has the same problem.

So I am hoping that Apple's new Samba wrapper will allow the Classic layer to see the Windows shares. Then I will be ready to make the switch to OS X at work (which would save me a lot of headaches - under OS 9, if a Windows fileserver goes down, 9 times out of 10 the Mac freezes)
 

m1mx

Registered
I've tried "smb://xxx.xxx.xxx.xxx/share_name" and still no luck.

I can ping the machine and it's there and I get a log-in interface but after typing in Name and Pass it comes back with "no server found" message.

Dave works great when running 9.2, but Dave 3.0 (demo) won't work with 10.1.

I hope they fixed this issue soon, it's the only thing holding me back from swicthing over completly.
 

ScottW

Founder
Staff member
Try a free program called Sharity... works great on the 10.0.4. It will allow you to connect to Windows shares.

Admin
 

knighthawk

Registered
If I remember right, the built in software is designed to access Windows network drives on NT machines not 95-ME machines. Does anyone know this?

It is not just Windows, I get that "server cannot be found" message a lot when trying to connect to the Appleshare drives of the Sunserver we use (I am still using 10.0.4).

One thing that I have noticed is that if you have OS9 set to automatically log in to the server, it works great when you start Classic. I also have aliases of the network drives on my computer, and they sometimes work, and sometimes say "the original cannot be found". Sometimes, the drive just "freezes" and I cannot see anything in it... when that happens, I have to reboot to get access to that drive.
 

m1mx

Registered
Just so you know Sharity doesn't work at all on 10.1. It's give a error on launch.
 

bookem

danno
I can access shares on a win2k server via appletalk or ip. the server appears automatically, and I can also type in the ip address.

I know what samba is, but I thought it had to be installed separately. I can't access files on a win2k pro machine at all, apart from via ftp.

Can anyone say what you have to do to get samba running?
 

knighthawk

Registered
This is from the Apple Website, about 10.1 new features:

Networking is also more compatible: Mac OS X version 10.1 now includes the ability to connect to AFP servers over AppleTalk making it easier to integrate Mac OS X into legacy networks with older AppleShare servers and Windows NT servers. We've also added support to natively connect to Windows NT, Windows 2000 and Unix-based SAMBA file servers with the built-in SMB client. These servers appear right in the Finder like any other file server. This makes Mac OS X fluent in all of today's network languages.
It says nothing about connecting to NT workstations or consumer machines (95-ME). That is really disappointing...

This is what Thursby Software has to say about DAVE.

<B>Why is this version FREE?</B>
When asked why a commercial software company would give away a key technology, company president, William Thursby, responded "Apple's engineers have done an outstanding job of supporting us. Unfortunately, they just have not been able to complete the key features to allow us to properly integrate DAVE into Mac OS X in a timely manner. We remain optimistic that we will be able to release a commercial version of DAVE for Mac OS X in the near future, but for now we felt that we owed early adopters of Mac OS X an interim solution."

<B>Limitations</B>
This free release will only work with Mac OS 10.0.4, and no formal support is available.
 

m1mx

Registered
"These servers appear right in the Finder like any other file server." I wish...

All I want to do is connect to my Win2k machine that runs into my router. With Dave on 9.2 it works great— no problems. OS X 10.1 is just not connecting to it thru the finder or thru command K.

I guess 10.2 well be the one.
 

Kazrog

Mac Metalhead
Actually, it does work in 10.1

First uninstall DAVE and/or sharity. The Dave uninstall is not totally clean. In Sherlock, search for dave and track down and delete any remnants of it (this may require logging in as root in terminal and manually removing some stuff.)

Then, reboot. Log in once you're booted and command-k to connect to server. If you're on a windows network, all you have to do is type in smb://workgroup;server/share and it will connect you to that share and mount it on your desktop.

It's not as seamless as connecting to a Mac server, in that it requires you to know the name of the computer and the share beforehand, but it does work and is very speedy.

I'm happy with it and I am now using 10.1 exclusively to do connect to Windows servers at work. It seems to work on machines running many different versions of Windows. I have found no compatibility problems at all.
 

SCrossman

MacTech
Originally posted by zeropage
in 10.1 it works like this...

smb://username@machine/volume

thats it!
That does not work for me. I was able to connect in terminal using a smbutil command, but then I could not see the drive through the Desktop. So Samba is there, just not implemented fully. I am trying to connect to a NT 4 SP5 server with cleartext password authentication. I also have Dave Beta installed and it doesn't work anymore. Maybe that is breaking the Connect for me. What kind of servers are you connecting to? To uninstall Dave, you need the installer, so thursby.com says. I don't have the installer and cannot find it on their servers.
How do I manually remove Dave from Startup? I cannot find it.
 

jedakroub

Registered
Though I don't have 10.1 yet, every example I've seen for SMB is as follows:

smb://workgroup;server/share

Even on Apple's site there is a QuickTime movie demonstrating SMB and this is the format shown. I cannot confirm it works in my work environment until Monday though.
 
Top