10.1 on Unsupported Mac


Has anyone got the 10.1 upgrade to work on an upgraded Mac with a G3 card? I have an 8500 with a Sonnet G3/500 card. The upgrade goes through the whole install then gets to the installation of the printer drivers and fails. It says "There were errors during the install. Please re-install" and the log file doesn't give any info on any errors. I've tried it on 2 different drives. I've tried updating from 10.0 and 10.04. I've tried not installing the printer drivers and the BSD layer but still fails at the end of the install.

Is your drive larger than 8GB? The firmware in these machines won't allow it to be installed on larger drives unless it is in the FIRST 8GB (or less) on a partition.

The biggest issue I had when installing the 10.1 beta was the lack of an ADB driver installation during boot processes. There are help solutions around, do a search for unsupported OSX and the name "ryan rempel." He has done groundbreaking work on getting OSX on PCI machines pre-G3. He also has the L2Cache enabler for G3 upgraded machines.

Other than that, I've heard of many people getting it to work. It runs really quite well (not zippy, but not super-slow either). Basically my 400mHzG3upgraded 7600 with 256MB RAM runs well, but it doesn't handle the load of many apps running simultaneously like my dual533 can.

It CAN serve web pages and play iTunes while downloading and keep the interface fairly fluid. Loading of apps seems a bit slower, but that could be the drive speed.

Just watch what extra cards you put in these machines. Some videocards prevent booting (at least in 10.0 and the PB). I think the situation shoud be better in 10.1 but haven't heard much evidence of it.
Neither drive I've tried it on is 8 Gigs. One is a 2 and the other is a 4. I have also tried using ryan rempel's utility and Sonnet's install utility and get the same results with both.
Sorry to ask, but have you formatted with Apple's Disk Utility or a 3rd Party. I had trouble with my installs when using FWB (I don't think it was the latest version, but it *did* work for 10.04 and previous).

After clearing and reformatting the entire drive (all partitions) it installed and booted fine.
I've gotten 10.1 up and running on my 8600/300 with stock 604e processor and 256MB of RAM. I'm actually quite pleased with the performance overall, its not that much slower than my G3 350, and it even handles Classic really well. Some things I ran into:

1. I have a Sonnet Tango Firewire/USB card installed - caused kernel panics every time I tried to install 10. Had to pay $30 to Sonnet to get their 10 install util, which worked just fine after the user errors were eliminated :)

2. My Wacom tablet runs great under the beta drivers now available for 10.1, and the USB ports are (obviously) working on the Tango. I've also got an Epson Perfection 610 scanner, which works great in Classic.

3. As on my G3, OS 10 isn't using my RAM very well. For instance, I'll have ~70MB of unused memory, yet the system is swapping to disk like its going out of style. Go figure. Its worse on my G3 – I have a full GB of RAM, and I'll have over half of it totally untouched, yet I'm swapping to disk. I just can't grasp why that would happen.

4. The system will sometimes pause for about 1-3 seconds, then just come back to life. This happens every so often. Not terribly annoying.

5. Here's the BAD part – for some reason I can't mount disk images. Disc Copy opens, attempts to mount it, then I get a system dialog box telling me that I've inserted a disk that Mac OS X cannot recognize, giving me the option to Eject, Continue, or Initialize. WTF? I've downloaded a TON of Disk Images, and none of them work. grrrrr. Anyone know a unix-y command for mounting disk images that might be worth a shot?

Other than the disk image thing, this install is very smooth. Definitely worth a shot, even without a G3 upgrade! If you don't have a Sonnet product installed, just use Ryan Rempel's utility. And if anyone has any ideas about how I can get disk images to work, or what might be causing the problem, please let me know!