10.1 on (yet another) unsupported Mac

Ripcord

Senior Lurker
Has anyone seen this before?

I'm trying to install OS X 10.1 on a virtually unmodified 7300/180 (I have installed a Crescendo G3/400 chip and some extra memory, however) with UUX, and am having no end of troubles. I've never had 10.0 or any previous version of OS X running on the machine before.

Obviously hundreds of people have had absolutely zero problems getting 10.0 and 10.1 installed on their 7300s (including Ryan Remple, the author of Unsupported UtilityX), but I'm trying to figure out why mine might be having problems.

After installing 10.1, the OS began booting for quite some time, then eventually I received a "Timeout: T/L = 0:0 Cmd = 00c18800 Cmd Type 2", followed by "PatchedIOSCSICDDrive [IOBasicSCSI]: SCSI bus reset occurred; begin recovery.", and "PatchedIOSCSICDDrive [IOBasicSCSI]: SCSI bus reset recovery complete.", and the system simply halted.

Sometimes the command associated with the timeout is "0141e600".

I've seen the same error in subsequent boots, though over time the problem has occurred earlier and earlier in the boot process. It seems to happen almost immediately after the boot process starts now, particularly during fsck's and that sort of thing.

I noticed that I always get the error message "loadkernelextension(): load_kmod() failed for kmod "oldworld.support.PatchedIOSCSICDDrive4K78" cannot be found.", then "IOCatalogue: oldworld.support.PatchedIOSCSICDDrive4K78 cannot be loaded.", then a series of errors that appear to be dependency errors based on the fact that this extension didn't load. I'm not sure if this is a real problem or not (I figure you perhaps try to load a slew of extensions, and some won't work and aren't required for all machines).

I've tried re-initializing the drive and installing onto a fresh drive, but that hasn't seemed to have made any difference.

I haven't had any SCSI problems in 9.1 that I know of, but I know X is much more touchy about SCSI problems. I've also noticed that the Installer hangs quite a bit (usually in the very last phases of the install), but nothing interesting appears in the log when this happens. However, I've checked termination, tried all combinations of termination, removed the CD-ROM drive, moved the devices around on the chain, etc., but I only seem to be able to make the problem worse.

I've also replaced the original 180mhz 604e, but it didn't make a difference.

I didn't think it was causing a problem, but I even tried removing the PatchedIOSCSICDDrive.kext, and didn't get the PatchedIOSCSICDDrive error messages on boot, but still got the timeout (with no "recovery" messages).

Any thoughts? I don't have another machine or another SCSI drive to test, but that's the only other route I can think of going with this. I bought this 7300 (and OS X) with the sole intention of running X, so I'd hate to NOT get it running!!

Ian
 

Ripcord

Senior Lurker
:D :D :D

I got around this problem, and I'm now running OS X 10.1!

I switched to the secondary (standard) SCSI controller in the 7300, from the primary (fast) SCSI controller, and things now work great!

Once I enabled the level 2 cache, OS X 10.1 actually performs faster than I expected. This is great!

Anybody have any ideas what might be my problem using the fast SCSI controller in my machine, other than the controller might be having problems?

Ian
 
Top