10.1 Startup delay - Starting directory services

xjohnson

Registered
Ever since updating to 10.1, I get this five minute delay when trying to "start directory services" as the machine boots up. I'm fairly confident this has something to do with netinfo, but I'm not quite sure what to do about it. These are the lines from the console right around where the delay happens:

Oct 17 23:14:39 localhost netinfod local[187]: setsid failed: Operation not permitted
Oct 17 23:19:44 localhost lookupd: NetInfo connection failed for server 127.0.0.1/local
Oct 17 23:19:44 localhost lookupd[194]: lookupd (version 233) starting - Wed Oct 17 23:19:44 2001
Oct 17 23:19:45 localhost lookupd[194]: configuration initialization failed: using defaults

This delay also seems to happen whenever I plug/unplug a network connection (now that's annoying!)

Don't know if it means anything, but I did have the dev tools and WebObjects 5 demo installed under 10.0.4, and now have the 10.1 dev tools installed.

-- Alex
 

Charles_So

Registered
I am having the similar problem... the Mac holds at "Starting application service" and "Starting authentication service"

Posted my problem a few thread earlier.

I don't know why it is happening, and am looking into it.
 

xjohnson

Registered
I took a trip over to the Apple-hosted discussion boards, and another person was having the same "starting directory services" problems. They deleted the "locations" section of the netinfo database and that fixed it. I tried it and it also worked for me. :) Now it just boots right up - no delay.

Deleting chunks of the netinfo database seems a little risky to just go trying out for a problem that *may* be related, Charles, so I'd do a little more checking of what your console is telling you before hacking up your Netinfo database. If it's giving similar messages to mine, it might be worth a shot. On the other hand, if you've got all your data backed up and nothing to lose, it might be worth a shot no matter what the console says. :)

-- Alex
 

Charles_So

Registered
Right! I'll check the board and see if any solution is posted.

I don't know what data in NetInfo is related to Application Service and Authentication Service, so it is risky.

Thx!
 
Top