10.1 System Preferences Launching is Buggy

FireWire

Registered
I have found a strage behavior in os 10.1. Normally when you go under the apple menu and click on Dock then click on Dock preferences, it would launch System Preferences and bring you to the Dock pane. This nolonger functinos for me. The same issue applies when you try to access the Network prefereces pane from the Network menu item in the apple menu.

If I go to the apple menu and click on System Preferences, all items open and work fine. The problem seems to be with the launching of a specific pane from a source other than the actual System Preferences app.

Anyone?

Tim
=-=-=-=-=-=-=-=-=-=-
www.saltedwound.com
 

Darkshadow

wandering shadow
Apple changed the name of the preferences, plus the name of the folder they are in. And double clicking on them doesn't open them up in System Prefs anymore.

I'd say Apple shot themselves in the foot by doing this and forgot to update the menu actions to open up the right thing. So these don't work -yet- (I'm sure Apple'll fix 'em).

Any 3rd party app that accessed a particular pane of the System Prefs is going to have to be rewritten to work with it again, so for the moment those won't do anything.
 

FireWire

Registered
I noticed exactly the same thing. Thanks for reassuring my assumptions. It seems odd that I haven?t heard more about this.
 

mcasteel

Registered
Very interesting. When I installed 10.1, rather than just updating the 10.0.4 partition, I re-initialized it and let 10.1 do a fresh install. The Apple->Dock->Preferences link works OK in this situation.
 

FireWire

Registered
Problem solved!

In your home folder go library>preferences>byhost>

In the byhost folder, delete any file (mine had 2) that has system preferences in it's name. (ex. com.apple.SystemPreferences.localhost.plist).

Once I did that, all of the Sytem Pref shortcuts worked again.

Tim
=-=-=-=-=-=-=-=-=-=-=-=-
www.saltedwound.com
 
Top