10.1 upgrade and PPPoe

bebox

Registered
hi all,
i upgraded to 10.1 this week and used to have a working pppoe connection at home. all i had was username and password and press connect and all worked fine. most of the time i didn;t even have to press connect...as soon as i woke up the computer it was on.

i have two locations - Work and Home. Work uses our linux router at work and things were fine when i got to work and everything worked great but then i get home and change the location to home (which used to work just fine) and then i get the connection okay but cannot surf the net and IE5 is set to work thru a proxy. I used to use a proxy setup at work and it looks as though the upgrade has well and truly friizled my settings somehow.

So i know it connects because i can use ICQ/ ftp via the terminal only and i can ping but cannot traceroute!

My mail won;t work at all and even LYNX from the terminal won;t work so it seems like some http issue and some settings that are stuck somewhere...it is driving me nuts and i cannot figure it out!! So i am using my old dialup to do stuff at home which of course is wayyyyy tooo slow ;)

can anyone pls suggest something for me to try...thanks :))

Jason
 

james.hodge

Registered
Bebox,

Interesting that you are listed as coming from Australia - bet you're using Telstra BigPond ADSL, right??

I have the exact same problem since upgrading to 10.1, on both a TiBook and an iMac DV. Both worked perfectly in 10.0.4, but have exactly the same problems as you're experiencing in 10.1.

At work we use ADSL routed through a NetGear router, which works perfectly as expected.

Unfortunately I've got no answers to this one yet - I tried rebuilding my location but I seem to have changed my password at some stage and am unable to remember what I changed it to so far, so the new connection won't authenticate and the old location has the problems you've described.

Any ideas, anyone???

Cheers,

james hodge
 

bebox

Registered
hmmmm..the plot thickens!

There is also a guy on www.ausforums.com.au which has the same problem..again with Telstra ADSL and 10.1....me thinks there is something strange going on.


Please can someone help us???? :))

Jason
 

james.hodge

Registered
Bebox,

There is a solution (a manual pain in the ass one, but you can at least use the net). - you will need to have enabled Root user using Netinfo to do this

Connect via PPPoE as per normal, then open a terminal window and type:

sudo ifconfig ppp0 mtu 1492

type your password, then bammo - the net works again...

you need to do this every time you connect though... bugger!

The story here (in my non-techo interpretation of real events) is that the default packet size in 10.1 is 1500, which is too large for BigPond ADSL to handle, so it gets only a few replies as most packets will be 'too large, resend' replies from the server. Hence the internet access that isn't NOT working, but isn't working either. The command above sets the packet size to something slightly smaller - this will cause the ADSL to work again!

I've been trying all afternoon to find the default location for this setting, but to no avail (other than by changing C Headers and recompiling 10.1....!).

Hope this at least gets you running.

james
 

bebox

Registered
Hey james you are the man!!
I am sure that would have been my next guess....yeh right!!
I have been pulling my hair out with this one ..deleting preferences etc etc so will try when i get home tonite...it will defin save me buying a pc box and setting up a linux router like i almost did..well..maybe almost did :))

If this works I will name my first born after you...Having to resort to dial-up again was not a good experience!!

Thanks and cya
Jason
 

bebox

Registered
Hi James,
Thanks you thank you!

Yep it works just fine and a mate of mine I spoke with tonite said they were doing the same workaround from a FreeBSD box...there you go!


Apparently there is now something at macfixit.com too from your post perhaps?

Cya mate and thanks
Jason
 

james.hodge

Registered
Bebox,

I'm still working on the permanant solution at the moment, but in the mean time here's a slightly more elegant way of doing things:

1. use vi/emacs in the terminal, or your normal text editor (eg BBEdit) to create a document called 'fixmypppoe.scp' (or similar - the .scp is the important part).

2. In this document, type:
#!/bin/csh
sudo ifconfig ppp0 mtu 1492

3. Save the document, then switch to terminal (if not there already) and cd to the location you saved that file

4. Type
chmod 775 fixmypppoe.scp

5. In the finder, double click the file you just created, and it should ask you for an application to open it with. Use the 'all applications' option, and choose Terminal.

6. Place a nice icon on the file, and stick it in the dock.

7. Now, when you logon to the net via PPPoE using internet connect or the menu extra, simply click on the icon you placed in the dock. Terminal will load - enter your root password, it will say 'Process Completed' then just quit the terminal, and your net is back to normal.

Hope this helps also - will let you know if I find a permanant solution before apple does.

James
 

bebox

Registered
Hi James,
Thanks again for your help..very much appreciated! Mostly I just put the Ti to sleep so hopefully will only need to run the script every so often...
Let's hope Apple reads the forum and fixes this annoying little problem :))
Damn shame to spoil such a great OS with little things that are easy fixed..

Talk to you later
Jason
 

Aussie John

Registered
James - that is good stuff
only trouble is i am new to OS X - what does

"3. Save the document, then switch to terminal (if not there already) and
cd to the location you saved that file "

mean.
Also Im not even sure how to get to the terminal.
I think I understood the rest

Regards John

Also I hope you have advised BOTH Telstra and Apple:) ( you seem to know what you are talking about)
 

james.hodge

Registered
Aussie John,

The terminal is the OS X way of getting to the UNIX system that runs underneath the pretty aqua stuff. The terminal application is found in Applications/Utilities/Terminal

A caveat with all this - the terminal is a pretty good way to do low-level stuff, but also a pretty good way to mess things up if you're not sure (especially if you get to root user, which you'll have to do in order to make the fix work). I've been through a heap of stuff I probably shouldn't have, and to no detrement, so you should be okay as long as you're sensible.

Anyway, the step you're talking about 'cd to the location you saved that file' involves changing the directory (hence cd) you're looking at in terminal to the place you saved your file. Terminal opens by default at your home directory (/Users/yourusername/), which is also represented as ~/ To carry out step 4, you need to change the terminal prompt to the directory you saved the file in. So if, for instance, you saved the file on the desktop, you'd type:

cd Desktop

If you saved it (for some reason) in Applications/PPPFix/AnotherFolder/ you'd type:

cd /Applications/PPPFix/AnotherFolder

Hope this helps you out somewhat - note that you'll need to enable the root user to carry out the fix - if you don't know how this is done just let me know (either here or by email james.hodge@beatentrack.com.au) and I'll give you some more info.

Cheers,

james

PS. I've reported the bug to Apple (as have several others I'm sure), but reporting it to telstra would be about as useful as asking them to waive my bill for the next 10 years...
 

bebox

Registered
Howdy James,
I was wondering if there was a possibility to run the PPPoe script at startup thereby negating the need to manually run the script because I could be using those precious few seconds to do something else ;)

Also I now have something weird in X.1 whereby no-one can connect to my local webserver on my Ti to test webdev work that I have done. I run Apache/mySQL/PHP and was wondering if perhaps something is linked with what we have been discussing.

I give them the address eg 123.123.12.123/~myusername/wmnews/index.php but nothing and noone can ping the address either. All sharing is turned on and all seems the same but I just suspect that the ole upgrade has screwed something else in my settings.

Thanks mate...
Jason
 

james.hodge

Registered
Jason,

By startup, I'm guessing you mean running the script every time you connect to the internet, which is what you need to do.

I suppose there are 3 possible ways this could be done:

1. If your PPPoE is set to connect when you first login, you could set the script as a Login item so it loads when you login each time

2. We could write an AppleScript which served the dual purpose of connecting to the internet via PPPoE, then ran the script (thus avoiding the extra clicking)

3. We could change the shell script we've just built to first create the connection to the internet, then run ifconfig. This is probably the best option - If I get a chance I'll try to figure this one out and get back to you.

With regards to the personal web sharing - are you sure that your sharing is actually started (ie you click 'start' in the sharing preferences panel, but does it change to 'stop'). The default 10.1 changed the name of an apache extension, but if you had already used the software updater to run the 'Web Sharing Update' on 10.0.4 (which you probably did if you are a frequent user of apache on your machine), this change was not reflected in the apache setup files.

This is also a simple terminal based change:

cd to /etc/httpd/

use a text editor to change the httpd.conf file:

Find the line
LoadModule apple_hfs_module libexec/httpd/mod_hfs_apple.so
and change it to:
LoadModule hfs_apple_module libexec/httpd/mod_hfs_apple.so

If this does not work, let me know and I'll have another think about it.

Cheers,

James
 

bebox

Registered
Hi James,
Script suggestions sound good....probably number 3 with the Applescript would be best until Apple fixes this thing :))

Everything seems in place with regards to the Web Server sharing..there really shouldn't be anything to do which is why this is stuffing me up. Everything runs spoton locally so I know that side is fine but I can't ping my own IP nor can any of my mates. Web Sharing is enabled and should work no probs!

This is indeed a strange one...Thanks for your help so far.

Jason
 

james.hodge

Registered
Jason,

How are you connected to the network with the other users who are trying to reach the webserver on your TiBook? Via the PPPoE, or a normal LAN setup?

If it is via the PPPoE, you might try changing the MTU value to another byte lower (ie 1484) - some other users overseas have had better success with this lower value than with 1492, although 1492 works perfectly in my case.

If it is via Ethernet, can other users access your computer through other methods (ie file sharing or SSH)?

You might also want to check your firewall settings - I am using Firewalk X on my TiBook and after the 10.1 update I had to go back and tweak a few settings - perhaps 10.1 has enabled some firewall settings without your knowledge.

Other than that, I'm as unsure as you are!

Cheers,

James
 

bebox

Registered
Hi James,
Thanks for the reply.

I am trying on PPPoe but everything works fine on our LAN at work....type in my IP on the LAN and there is the webpage from my Ti as it should be. I do not use any firewall at home on my Ti (prob should though).

I can SSH into the Ti no probs at all.

I will try the lower setting for the MTU and give that a go. It is very weird!

So do you do any webdev work and have people access from outside? and does it work fine now with your upgrade?

Thanks and I will keep trying..
Jason
 

james.hodge

Registered
Jason,

I don't actually use my Ti for web serving - most of my web dev work is ColdFusion based, so it needs to be run on a Linux or Win2K box, which means that I don't host anything locally.

Seeing as everything works perfectly over the LAN, but not PPPoE, I'd put my money on being another setting related to the MTU (maybe not that again, but definately something similar). If web hosting works on a LAN it's not your firewall settings, so it must be another Telstra quirk...!

As SSH uses encrypted packets, they're only going to be of a fixed length anyway and even if you're using 1024 bit security (can SSH do 1024 bit keys??), an SSH packet should only be around 1100 bits anyway, well under the limits we are changing here. On the other hand, http packets will try to be as big as possible to reduce transmission overheads, so the fact that you can SSH over PPPoE, but not see your web server, suggests that packet sizes may indeed be at play.

It may be worth trying
sudo ifconfig ppp0 debug
and checking the console output for the extra logging that will occur when you try to get to your web server / SSH server etc. The answer may lie in there somewhere.

Hope you sort this one out!

Cheers,

James
 
Top