10.1: what happend to wget?

sps

Registered
Has anybody else noticed that wget is gone?

I think it odd that the updater would remove wget, maybe it was part
of the dev tools (which i have installed )



I tried to build wget-1.7
but I got this error in html-parse.c

cc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/usr/local/etc/wgetrc\" -DLOCALEDIR=\"/usr/local/share/locale\" -g -O2 -c html-parse.c
html-parse.c: In function `advance_declaration':
html-parse.c:449: character constant too long
html-parse.c:449: parse error before character constant
html-parse.c:449: stray '\' in program
html-parse.c:454: character constant too long
html-parse.c:461: character constant too long
html-parse.c:472: character constant too long
html-parse.c:481: character constant too long
html-parse.c:481: character constant too long
html-parse.c:481: stray '\' in program
html-parse.c:773: Unterminated string constant
make[1]: *** [html-parse.o] Error 1
make: *** [src] Error 2

Its probably something silly, but i don't have the time (or know-how)
to figure it out.

anyone?

--
-------------------------
Sean P. Scanlon
http://bluedot.net/
perl -e 'print pack("h*", "3707370426c6575646f647e2e65647"), "\n"'
-------------------------
 

Soapvox

Want some of my Kool-aid?
I miss wget...
They replaced it with curl, which I have never used, but found if you are downloading with wget, then just replace the wget part with the command
curl -O (then url)

It works and gives a little more response than wget but I still miss wget, I have tried installing it via fink but haven't tried to use it since installing (its on my other machine)
 

Red Phoenix

Registered
Wget does seem to work just fine after installing it with Fink, although I'm not completely sure I've compiled it since installing the 10.1 update. There are definitely a lot of times when I prefer wget over curl. For some reason with curl, if the file doesn't exist, it still creates an empty local file with that name. I'm sure this can be turned off, but it doesn't make sense why it does it in the first place.
 

travelgz

Registered
Yeah, what is fink? Is that a website or a command to get wget?

G
 

Red Phoenix

Registered
Fink is a great program that downloads, compiles if needed, and installs at ton of programs (you can get it here). A lot of them are X-Windows related, but there are many others, such as wget 1.7, pine 4.40... The real usefulness comes when a program needs special configuring to be run on OS X, or the code needs to be patched before it can even be compiled. Fink does this all automatically.

To get an idea of the enormity of Fink, this is just a snippet of what typing fink list on my computer gives:

sudo /Volumes/Icarus/sw/bin/fink 'list'
Reading package info...
Information about 409 packages read.
a2ps 4.12-4 Any to PostScript filter.
abiword 0.9.3-3 unix gtk+ version of open-source, cross-pla...
afio 2.4.6-1 Archive file manipulation program
afterstep 1.8.8-1 Alternate Window Manager
align 1.0.0-1 Text filter that vertically align columns
amaya 4.2.1-1 [Package amaya version 4.2.1-1]
i anacron 2.3-3 A periodic command scheduler
i ant 1.3-2 Java based build tool.
apache 1.3.20-2 Flexible and extensible web server
app-defaults 20010814-1 Creates an app-defaults directory for fink
i apt 0.5.3-7 Advanced front-end for dpkg
aria 0.10.0-1 File downloader, similar to GetRight.
aterm 0.4.2-1 Afterstep XVT - a VT102 emulator
atlas 3.2.1-3 Portably optimal linear algebra software.
i audiofile 0.2.1-2 Audio File Library
autoconf 2.50-1 System for generating configure scripts
i autoconf25 2.52-1 System for generating configure scripts
autocutsel 0.2-2 Merges two cut buffers used by X apps. Like...
i automake 1.5-1 Makefile generator
babel 1.6-1 Molecular modelling file converter
i base-files 1.2-1 Directory infrastructure
bash 2.05-3 The GNU Bourne Again SHell
bbkeys 0.8.2-1 Key binding handler for Blackbox
bbmail 0.6.11-1 Email-watcher designed for use with Blackbox
bbpager 0.3.0-1 A pager tool for the Blackbox window manager
i bison 1.29-1 Parser generator
bitchx 1.0c18-2 IRC client


The i says I've installed it. You'll notice there a over 400 packages (although my number is probably a little bit more than the average user's). That's why I play it up so much; I got it to install something a while ago, and I just keep finding more cool stuff to install.
 

travelgz

Registered
Hi,

I downloaded wget1.7 tar ball. I ran configure and here's what I got:

checking for cc... cc
checking whether the C compiler (cc ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.

I typed cc and it exists (not that it works). So what does it mean? I need update my cc?

Thanks!
G
 
Top