10.3.9 And Programs Not Working


alright. here goes - i apologize if this is long-winded, there are quite a few factors at work here.

my boss recently updated to 10.3.9, as well as quicktime 7 pro, and now adobe premiere isn't working as it should, as well as other programs.

the computer is a G5 tower, 2.5 ghz, with a myriad of audio production hardware elements hanging off it. (we do audio post production). i attempted to digitize video using a canopus ADVC100 connected via firewire, using adobe premiere 6.5. this is the way i always do it, and it's worked smashingly up until the 10.3.9 update. but now, if the ADVC100 is powered up and the firewire connected, premiere will not boot up past the initial "choose your sequence setup" window. you click OK, and *poof* it quits. if the ADVC is turned off, and premiere is booted up, it comes up just fine. now, with the program running, if the ADVC is powered up, premiere quits instantly.

the problem isn't with the ADVC, i've used it recently with another (non-10.3.9) computer and premiere, and it's successful.

i don't understand what the conflict is here. is it a firewire conflict? is it to do with quicktime 7? does premiere 6.5 not work with 10.3.9? the computer sees the ADVC just fine, and imovie will capture from it.

final cut pro 4 does the same *poof* quit thing when you initialize the log-and-capture function, while the ADVC is connected and on.

and just today, toast titanium 6 has started to act up. it boots up, and then quits. i'll try the update for that one, i think that may solve it.

have you heard of any bugs like this before? do you have any idea whatsoever what's going on? help me please!!! any input is appreciated. i'd rather not have to reconfigure the video setup of the studio, which i'd have to do if this can't be fixed somehow.

as for my technical level, i know more about macs than an average joe, but i'm not an expert. my experience comes from using them every day for audio editing, and having to fix problems when they arise.

again, any help would be appreciated.
I'll say first that I'm no AV expert, but I'll chuck a couple of things in the pot - who knows -it may help :D
10.3.9 has caused some problems for a multitude of people (please don't glibly go to Tiger!).
Firstly, you must repair permissions after any OS update - this can be done through Disk Utility or the command line (if you didn't know!).
Anything vaguely sensible in the error logs? (In Console utility).
Since there is no inbuilt 'roll back' feature in OS X, you must eliminate what upgrades you can - Apple have released a package to allow a decent reverting to QT6.5.2 when you'e using 10.3.9 and QT7.0.1- see http://www.apple.com/support/downloads/quicktime652reinstallerforquicktime701.html - they must have released it for a reason??
Check as to wether the Premier site on adobe.com has had any other comments about this - it would also be worth checking the latest version of Premier?
As far as Toast goes, I run 10.3.9 on a Mac using version 6.0.9 with no problems (I stopped short of 6.1 'cos of various copyright things).
Let me know what happens - ATB.
thanks for the suggestions; however it seems this problem is a nasty, persistent little bugger. repairing permissions didn't work. neither did trashing the preferences for any of the problematic apps.

the biggest little problem at the moment is toast. i had 6.0.3, which up until a week ago was working just fine. i updated to 6.1.1, thinking it would solve the problem of spontaneous quitting 3 seconds after initializing; it didn't. what updating did was get the program stuck in a damn annoying loop - click to open, go through the fresh install set-up process, it quits. i tried installing (after deleting the 6.1.1) fresh from 6.0.3, then updating to 6.0.9, same result. an endless set-up process.

i'm at my wit's end on this one.

oh, i did look at the console, though my mac-fixit knowledge is not that advanced. i couldn't make heads or tails of it, except that it said the same thing for every time toast quit on me. i'm no longer at that workstation, so i can't tell you what exactly it said. (will check tomorrow).

i followed your link to the quicktime downgrader-updater, but unfortunately we need quicktime pro 7, so downgrading it to regualr 6.5.2 isn't a feasible option. i hope that's not what's causing all these problems; i don't think it is, since the problem with toast just started a week ago, and OSX 10.3.9 + quicktime pro 7 have been up and running for a month or so.

*delated sigh of frustration* i have no idea what else to do, besides setting up a new user and seeing if it's a problem with the regular user's preferences and setup. (will try that tomorrow).

premiere is still up to its tricks and not starting. at the moment, it's the least of my troubles!
oh - regarding premiere - i did check on updates and compatability stuff on the adobe site, which was of little to no help. considering i'm using a less-than-official copy, updates aren't an option.... :)
Which would explain why Premiere and Toast (plugs into Quicktime) aren't working. If you haven't already, do try downloading the re-released version of Quicktime 7, and re-install it, remembering to repair permissions afterwards. You may have to revert back to Quicktime 6.5.2 first, but I hope not.

Also, for future reference, with a mission critical production setup like yours, it is HIGHLY recommended that you have a sacrificial Mac to test all major system updates on BEFORE you install them on your production rigs (learnt that lesson myself the hard way). A old, second hand machine sitting around somewhere (or your own Mac at home) with a mirror of your software setup (should be able to use your existing licenses, as long as you keep it off the network, or you require dongles) is quickly paid for when you count up the value of avoided downtime.

Good luck resolving your issue.
your suspicions on quicktime 7 being the culprit were just proven wrong, to my amazement!

on a roxio toast help thread, i found a tip to delete the .plist file and toast will work again. so i did that. and it worked. tried the same thing for adobe premiere; hooked up the ADVC 100 converter box (firewire), premiere still crashed. tried toast. now toast was crashing again.

unhooked the ADVC, deleted the .plist for toast, and it started worked again. which leads me to believe it's some wacky firewire conflict with the ADVC and 10.3.9.

without the ADVC hooked up, premiere works like a charm, even exporting and rendering, which (i read) someone had troubles with after installing QT7.

i'm wondering if this is as simple as a firewire drive with corrupt directories or something. the ADVC is hooked up into a LaCie firewire drive, which is then connected to the G5. i'll try connecting the ADVC straight into the G5, and also verify the firewire drive's integrity.

would something like a corrupt firewire drive (or port on that drive) be able to cause these strange problems?

keep ya posted. and, thanks for the help and suggestions!