10.4 Disk Mysteries - No Access Permission


I recently wanted to secure one of my internal drives because it contained some confidential material so I went to the get info window for the drive and changed the “you can” disk permissions to no access. I had done this in OS X 10.3 and I know the disk could be easily assessed once again by changing it back to Read & Write, but I was counting on others not being savvy enough to change permissions back to read & write to gain access. However when I rebooted my system the drive no longer showed up on my desktop. The Drive showed up in the disk utilities as already mounted and there were no repairs needed, but still didn’t show up on my desktop. Disk Warrior also reported the drive in good condition. I had Disk Warrior write a new directory fro the drive, but the drive was still not available on the desktop. I eventually booted from the Tiger CD and noticed it would see the disk and allowed me to write system files to it. This seemed to fix it.
I then did some experimentation and noticed the following results. If I was running OS X 10.4.2 and I changed the disk’s permission on the “you can” menu to no access and then immediately tried to change it back the system would reset it back to no access. The only way to gain access to the drive was to format it or write system files to it. If I boot up on a disk running 10.3.9 I can change this same permission to no access and back to read & write with no problem.
I also noticed a stripped disk I stripped in 10.4.2 and mounted normally, no longer mounted in 10.3.9. and I received a message asking if I wanted to format the separate drives. When I return to 10.4.2 the striped disk is mounted again with no problem.
This a single user system which is not networked to any other computers and I am the owner. It is a dual gig G4, 1.5 gig of ram, 1 TB made up of 5 internal disks.
I was wondering if you had insight in regards to what I am experiencing.

PS: This seem very similar to a submission you received on Aug. 31 2005, 8:48am titled : No Access Permission - Now No Hard Drive On Desktop from Luke