2 problems with 10.1

uoba

Re: member
Firstly, photoshop files when viewed in the Finder Column mode don't preview correctly (they look like badly pixelated jpgs!)

Secondly, doubleclicking Classic documents (Indesign or whatever) in the OSX finder will only open the application (or bring it to the front) but not load the document!

Anyone else had this?
 

sithious

no longer a member
Originally posted by uoba


Secondly, doubleclicking Classic documents (Indesign or whatever) in the OSX finder will only open the application (or bring it to the front) but not load the document!

Anyone else had this?
doesn't happen to me ... i've got quite a few .rm files which have to be viewed in real player under classic. clicking on a file will start up classic, start up the app and play the file ...

as far as i remember i designated real player as default app in the info box for the files ... don't remember the reason why i did this, but it may have helped ... ?!?
:)
 

solrac

Mac Ninja
OS X is not to blame.

First, Photoshop is making ugly pixelated icons, because it is making the correct icon format for OS 9. (32x32)

When Photoshop 7 for OS X comes out (couple of months hopefully), it will no doubt create 128x128 beautiful preview icons. It better!!!!!!

Second, sometimes classic apps will not open a document unless you select file...open...

Try quitting the app and restarting it.

If that doesn't work, stop classic and restart it.

If that doesn't work, reboot your computer and start classic.

That's actually not worth even worth the time. Just use file...open... if it still doesn't work after the first 1 or 2 tries.

-solrac-
 

uoba

Re: member
Firstly, I meant that the Photoshop files not as Photoshop ICONS but as a preview of the actual file/design I am working on -- it previewed the file fine in the finder for MacOSX 10.0.4.

Secondly, as far as I could remember Quark was the only app in OS9 that would load the file if doubleclicking on it in the finder -- every Classic app is now refusing to do this (Photoshop etc.)

;)
 

sithious

no longer a member
just tried it with a couple of classic apps... they all open the document right away.
must be something wrong with your install ...

apps that opened their documents on double clicking the document:

real player
adobe page mill
simple text
picture viewer
apple works
toast
 

uoba

Re: member
Can you preview Photoshop files in the column view of the finder?
 

sithious

no longer a member
Originally posted by uoba
Can you preview Photoshop files in the column view of the finder?
sorry, i haven't got any photoshop files to preview ... :)

can you post one here?
i'll give it a try... :)
 

walrusjb

Registered
Classic opening of files from Finder sometimes glitches for me - not too often, though.

But the Preview in Finder is definitely buggy - this was so smooth in 10.0.4 - and it doesn't just apply to PSD files.

Solrac - this is not the icon preview. The icons in the column view, icon view, etc. are fine, albeit 16x16 or 32x32 and resized as needed. Preview app will open PSD files natively - you simply can't edit them. And in 10.0 - 10.0.4 this functionality extended to Column view of the Finder as well... which was sweet.

In general - I'm finding this with PSDs, a number of JPEGs (can't tell why it previews some and not others yet), and *some* PDF files. I heard a rumour not long ago that the PDF preview was killed as it locked the finder on larger documents - but don't know why this would be carried over to PSD files as well - the PSD file format includes a "merged preview" layer already - 100k or so worth of the file that is essentailly a JPEG...

Don't know, but I'm going to send feedback to Apple on it... I forget about it from time to time and then it chaps me when I remember.

-jb

**edit** Sent Apple feedback - suggest others do the same and maybe it'll get fixed one of these days. Definitely a bug as I just ran through 50 or so odd files and only 2 of them showed their preview correctly. It *does* show it correctly, even on pixelated ones, if you open an info window and choose "preview" from the dropdown... so somewhere in between something's not cooking. This DOES NOT make it reappear correctly in teh finder window - but is a faster option that opening P-shop to see through the pixelation.
 

uoba

Re: member
This was one definate excellent feature of OSX column mode, but I don't fancy looking at those pixelated previews, I'll follow suit a send APple feedback
 

beverson

Registered
Originally posted by uoba
Secondly, doubleclicking Classic documents (Indesign or whatever) in the OSX finder will only open the application (or bring it to the front) but not load the document!

Anyone else had this?
YES! I've been trying to find others with this problem. It's been driving me batty. I have it on my iMac and my iBook, my G4 at work, and I saw it on 15 different iMacs that my employer borrowed from Apple for a conference we put on a month or so ago (right after 10.1 came out). I've tried rebuilding the desktop from the Classic pref panel and rebooting any everything that's been suggested. Doesn't seem to help. And I don't remember this problem in 10.0.4, though I didn't use it nearly as much as I'm using 10.1 at home. Can't use it at work yet because of this bug and Connect To Server weirdness (the only way I can reliably connect to other machines is if I have the IP address, and because of our DHCP server....) and because I'd be in Classic all day anyway.
 

Jadey

sosumi
I have another weird glitch with photoshop in classic under x.1. This didn't occur in earlier 10.0.x. With photoshop already open, if I drag a picture's icon onto the photoshop icon in the dock, it opens in photoshop - unless that file is on the desktop. If the picture's icon I drag is in a folder, it opens fine. Not so if I drag it from the desktop.

Another issue: if I launch classic by launching photoshop, the titles in the menu don't show up - just a grey bar. I have to launch classic in the system prefs, then launch photoshop (or quit photoshop and relaunch it).

I also get that glitch you guys have reported that dragging an app to photoshop doesn't open the picture, just the app (if photoshop isn't open yet).

I suppose these issues I'll just have to deal with. I doubt Adobe would release a patch to make it work more smoothly under classic, and to be honest, I'd rather they spend their developing time completing the X version anyway :)
 

knussear

Registered
Is the classic app you are trying to launch a 68K app?

I have found that ppc or fat apps fire up and will open multiple documents on a double click from the finder, but that my 68k apps (e.g. the classic cricket graph 1.3.2, Superanova 1.1.1, which are both irreplaceable) open the first file on a double click, but none after that.
 
Top