4K73 Install Demolished my .app icons


I just installed K73 on my system which has been using K60 perfectly, and after a prolonged restart period, after I'd logged in, almost all of my applications are showing up as folders, most of my Dock icons are folders, and I'm unable to launch any applications. Known problem? Anyone have a fix for this? I'm heading back home to see if I can fix it, but I'm hoping I haven't ruined my X partition.
If it helps, I'm on a B/W G3/400, 256MB, seperate X and 9.1 partitions.
Thanks for any help in advance!
Sorry cant help you cause I am still in 1H39 which works well for me till I get version 1.0

I dont get why people waste their time with "newer" builds ( a.k.a. post K60) since the new, improved, final OS X 1.0 will be in stores (and probably on pirate servers) on or by march 24th which is about 2 weeks away :p

This software is not guaranteed to work and can possibly do harm to your mac....

when will ppl learn.....

PS: my sincerest hoppes that you get his fixed ;-)
This is a known issue when installing over a previous install. If you reinstall and check the clean-install option, all will be fine. You might just try re-installing over it again and see if that fixes it.
Well, if I were a run of the mill user, I wouldn't be pulling pirate builds and installing them, but the builds I've installed over the last 10 months or so (from DP4 on) are legitimate builds provided to me as a registered developer and a Macintosh reseller. I can't sell the product effectively if I can't support it, and I've been doing a lot of experimenting with AppBuilder/InterfaceBuilder, as well as testing the compability of AppleScripts. I sell to corporate customers, typically in large networked environments, and I need to be able to answer question, provide support, and generally know what I'm talking about. That and I get to play with the new OS :) Last time I had this much fun with new Apple software was the Geek Week WW Engineers conference back in '85, when I got to work with Copland hands on. It's amusing to still see things introduced as "new" in the current MacOS that were actually years old and originally scheduled as part of what was going to be "Mac OS 8".

I probably should have waited another week for the GM version that's coming back from the OSX Boot Camp this week, but I was having some issues already with 60, and had 73 here, so I figured it was worth a shot. Bzzzt, wrong answer. Oh well, I got things mostly back in working order.
Have a good one!
I would like to be an ADC member, but only for teh CD mailings lol... how can I do that ???

I got a copy of copland (one of the many) but never tried it. I actually got it recently but been feeling lazy in firing up my old performa lol.

IF you are legit and a developper it seems normal to do this, but, if you are just an average joe...what's the point ? :p

It would appear that I have a similar problem - I'm not seeing any application icons - they all have folder icons. This happened to a computer that perviously had OS 9.1. It was the first time installing X on it, and its really messed up.

First time installing X, X installed, and the computer reboots into this fancy setup program. I went through it all, until I got to the timezone selector. When I pressed the pulldown menu, the setup program sort of disapeared. And I was in a non-functioning aqua interface (nothing would run).

So I tried re-installing os x. X said it needed abour 350 mb of space for an 'upgrade'. Clicking on the "format and erase disk first" option changes the install size to 1.1 gb. Well, I didn't want to erase my copy of os9, so I did the 350 mb option. It installed alot of stuff, rebooted, and just drops me into the same old messed up aqua. (btw, using the '>console' command was interesting - nothing would run except standard unix console programs, and the rastorized text would sometimes appear to run over top of the screen - such as when I typed clear. And then I would have to reboot).

Well, I booted up with my os9.1 cd, and erased my 'Macintosh HD' partition. Mind you, I had backed it up before attempting any os X installs into a folder on another partition. After erasing the partition, I dragged my os9 system folder back into the Macintosh HD partition. Now my somputer was like it was before. Working.

I tried installing os X agian, and with similar success - no working applications. Calculator.app looks like a folder. Apparently, with my new install, I can't even open the folder because I don't have access. Wait a sec... I'm logged in as root, with admin privliges, I thought... oh well.

Well, I'm pretty stumped. I guess I'll call the os X help line on monday. Btw, Booting into os 9 is really hard to do. Holding down opt/alt on startup gets os9 up, but it doesn't have any of my preferences (desktop pattern, etc), and none of my extentions load. And, when I select my 'System Folder' in the startup disk control panel (either the one from my hard disk, or from the one on the os X cd), the finder grabs my attention with a message like "The folder 'System Folder' needs to contain the files 'System' and 'Finder' inorder to startup correctly. Are yopu sure you want to continue?" Well, those files are in that folder. I tried rebuilding the desktop (I was getting desperate) and it didn't change anything.

If yall think it will help, here's my partitioning scheme:
(these numbers are to represent order, not necessarly every partition on the diske - such as apple-patch partitions and such)
1) Macintosh HD - contains os 9.1 and os X (2 gigs)
2) Files - thats where I place my programs and documants (17 gigs)
3) root - thats an apple_uinix_server partition I use for Yellow Dog Linux (17 gigs)
4) swap - Another partition for Yellow Dog Linux (128 megs)

My computer is a rev.A beige power mac G3 266 with 128 megs of ram, and a 40 gig ata hard drive. I've also got an additional network card (which the os X installer seams to know to use when it connects to apple with my name and address), a Rage Orion pci video card (in addition to the on-board video), and a firewire-usb combo card (os X seams to recognize the usb mouse I use).

Anything would be appreciated. Thanks
I talked with apple the other day about my problem, and they said this:
Open up a finder window. Click the home button.
Open the folder 'Library'. Open the folder 'Preferences'
Delete any files containing 'LS'.
Well, on my computer, I wasn't 'allowed' to open the library folder.

Apple also recomended, if that didn't work, to disconnect every 3rd party card and device (scanners, burners, firewire cards, etc etc). Good luck to yall with this killer os.
Like many people, I have problems with applications which appear as folders on the finder. I started to install MacOS X (master release, in french) on my G4, on the same partition as MacOS 9, by mistake, so that I deleted it. Then, I installed it on a reserved partition, and then no icons, just folders. After many undefined, removing the LS files, the .plist files, reinstalling, initializing the partition, nothing could have my icons back again. So, I have reformatted the whole disk, made a new partition table, reinstalled MacOS 9, recovered by backup, and then installed MacOS X on a separate partition, and then again, no .app icons.

So, what can I do now ?


350 Mhz / 320 Mb / 10 Gb
with Adaptec SCSI adaptator, Stealth Serial adaptator and a few things plugged on it.
Hey, I went through the same crap when I first got the OS.
Here's what I think it is (well, Apple told me this was it, and they seem to be correct):
Being a cool unix guy, I thought I would name my first account "root". BAD idea. Mac OS X comes with a disabled root account built in. (You enable the root account later in the netinfo panel...) So, when you start out with an account named root, bsd gets confused.

You can't have two users with the same names and DIFFERENT UID's. Therefore, when this does happen, you end up with a user named 'root', and zero privileges. (Applications appear as plain documents because you don't have privileges to even execute them.)

So, just re-install and pick another account name in the initial setup.

Hope this helps. If not, reply. Also, CALL apple. They have a 1800 number. I think its 1-800-appl-care. Its free, but you do have to wait on hold quite a while sometimes.

Good luck with OS X.
I had to completely format and reinstall my hard drive to get this problem to go away when I got the final version of osx. It sucks, but it works a ton better when you do this.