AbiWord

lotrfan

Registered
Has Anybody tried to install AbiWord yet. (From AbiSource).

I went to http://www.abisource.com/downloads/version-0.7.13/lf/ and downloaded a copy of almost everything there. I put them all in my home directory, and did the following

%cd /users/lotrfan/abi

(tried to do ./configure here, but it did nothing)

%make

And it all seemed to be working great and wonderful, until is said
"checking host system type... configure: error: can not guess host type; you must specify one"

How do I do this? I've used AbiWord before in linux and thought it had potential (even if it is still in development), particularly since it opened Microsquish Word documents for me. Anybody who could help with the compile would be my hero for the next 6.8 hours

Thanks
 

glowurm@mac.com

aH-NAH :: GHASAD-Ha
*NOTE: this is a guess...

I have picked up in the forums or from chat or somewhere that OS X cannot decide "what to call itself. Sometimes it thinks it is darwin, others OS X, other times bsd..."

The context was regarding the host name, other than that I have no clue. Perhaps this refers to how the kernel identifies itself to an application? Wouldn't this make sense since an application must be compiled differently for individual OS types?

Remember, I am a geek who hates to code. I am guessing...


----------------------------------------------

*Additional Note, added 3/28:

(grin)I now see that the original poster had far more knowledge than I at first realized and understand that "As Usual" I shouldn't have stuck my big nose in. (/grin)

[Edited by glowurm@mac.com on 03-28-2001 at 12:50 AM]
 

scruffy

Notorious Olive Counter
This is what works in PB (no GM installed yet):

<tt>cp /usr/libexec/config* .
./configure
...</tt>

The config.guess and config.sub files contain info related to OS X. You might have to copy the files into various subdirectories - wherever there's a configure and a makefile, you will likely need to copy the config files.

Mind you, this doesn't always work - sometimes just gets you further into the build process before something barfs.
 

lotrfan

Registered
Scruffy, you were right. Some of the config.guess (maybe config.sub too) weren't aware of darwin. I substituted current ones for the old ones and everything started going along great.

Then it couldn't find malloc.h, but I found a file labelled this elsewhere in OSX. Don't know if I'm supposed to do this, but I placed a copy of this in the folder where it was needed.

Things went a little further along, but eventually hung up. Not quite sure why. I tried both versions 0.7.12 and 0.7.13. 12 seemed to go farther, but finally hung when it couldn't find some mac specific files.

I'll keep trying, but if anybody out there has successfully compiled AbiWord, please let me know.
 

AdmiralAK

Simply Daemonic
OS X is a collection of darwin, aqua, quarz, classic, and some more layers. Darwin is just the core, non-gui part of the OS, and it is a flavor of BSD coupled with the Mach kernel which both came from NeXTSTEP.

no confusion here.
 

vertigo

Swollen Member
you can specify the host type manually when running configure if there's no explicit support for darwin/macosx in the distrib:

./configure --host=CHIP-VENDOR-SYSTEM

i usually just use POWERPC-APPLE-MACOSX, although i don't think it matters a whole lot if there's no built-in support anyway :)
 
Top