Abs Not Distributing Ip to Hardwired Imac


Our house was nearly struck by lightning about 2 weeks ago. The electrical, cat 5 & telephone cabling was all hit pretty hard. Some components fried, including the dsl modem, Netgear RP614 4 port router, ABS power cord, PB power adapter and an iMac ethernet port. Everything was on fairly new surge protectors, except the fried iMac. The old LAN configuration was dsl modem -> Netgear router -> ports in each room w/ 2 iMacs and the ABS off the ports and the system was rock solid. Per Apple, I reconfigured the LAN as follows: dsl modem -> ABS Extreme -> Airport Express -> PowerBook. The ABS also is also connected to a Cat 5 cable that goes to an iMac running Panther. Apple tech support walked me thru this setup and it worked fine then. The ABS is distributing the IPs now, whereas the Netgear was doing it before. The PB is getting the IP, but the iMac, which was getting an IP is now not getting anything and my teenage daughter is frantic. And she loves her Bondi Blue iMac. As I indicated, the iMac was getting an IP from the ABS for a while. No new downloads, firewalls, little snitch or anything else added to the iMac. Just one day it's getting an IP and the next it isn't. The ABS firmware is the latest.

I suspect the following, but would like some ideas, if possible...
1) the other iMac's ethernet port was working, but took the hit also and eventually failed; 2) the in-wall cabling eventually failed; 3) the Panther on the iMac needs to be updated to Tiger; 4) it's time to buy a mini; or ? I've tried turning off the iMac, the dsl modem and the ABS in the sequences outlined in many a post, w/o any result. I'm thinking I'll go back to the old configuration. The ABS is a little cranky handing out the IPs to any ol' hardwired computer, it seems.

I do not want to buy an old Airport card off eBay to see if the iMac will get the signal that way. I'm not that much of a DIYer and the savings are not compelling. I did think of buying a used ABS and connecting the iMac to the Lan port, but that's a kludgy fix, too. Thanks for any suggestions or help.