Accessing httpd.config problem - HELP!

leswoods

Registered
Hi,

I'm trying to get to grips with the power of MacOSX and am trying to set SSI up by following an article in MacWorld. Its pretty idiot proof - but I'm having problems! I'm the only user on the machine and am a Administrator Here's what I'm doing:

1. Web sharing is on
2. Open Terminal
3. Type in
sudo chmod g+w/etc/httpd/httpd.conf/etc/httpd
4. Enter Password
5. Open TextEdit and Open /etc/httpd/httpd.conf
6. Go down to where you add Include - no problem
7. Go to server-parsed and uncomment directives AddType and AddHandler and set for .shtml - no problem

Now, the problem is that when I go to step 8:

8. Save the file

It says that it is a read only file and then if I try to overwrite it I get "Couldn't save document as /etc/httpd/httpd.conf"

It looks like the permissions are set so that you can only read and execute - I can't save it.

Can someone out there please guide me on how to do this?

Many thanks in advance!

Kind regards
Les
 

cody

Registered
skip textedit and just edit the file in a terminal text editor as root. i.e. "sudo vi /etc/httpd/httpd.conf" though if you're not familiar with the vi editor you can always do "sudo pico /etc/httpd/httpd.conf"
 

Digimatt

Registered
You can also boot with your OS X CD and change your root password. This will allow you to login as root.

Restart from the hard drive and login as root. Now you can edit httpd.conf with any text editor you want.
 

boysimple

Some guy
leswoods - did you manage to get SSIs working? I've gone throgh all the steps myself but they won't work in my Sites directory.

E
 

kilowatt

mach-o mach-o man
I can't remember off hand, but I did get this to work in the Sites directory (aka the ~User stuff).

If memory serves, it has to be loaded in the user section of the file, too. Or something. Well, I'll add to this post tomarrow. But to boost your spirits, its easy to do.
 

boysimple

Some guy
so it does have to be specifically specified to work in the user directories! that was the pointer I needed. Danke mucho, yo.

the trick was to edit the /private/etc/httpd/users/username.conf the Options line there needed to have includes added to it.

shoulda looked there sooner.

E
 
Top