activating TCP Wrappers for ssh connections

Zeus

Registered
I'm on mac os x 10.3.9. I've created /etc/hosts.deny and /etc/hosts.allow but i think sshd is not reading it.
Is there anything to be done for activating tcpd ?
do i have to edit also the ssh /etc/xined.d/ssh file ... probably yes ... but ... how ??


thanks
 

lurk

Mitä?
Are you running TCP Wrappers at all. I think you might be a bit confused on the matter. If you have a vanilla setup simply go the Sharing pane in the system settings and turn on "remote login" and you will be set.
 

Zeus

Registered
I think you might be a bit confused
mmm ... probably !
So this i what i'd like to do.

I need to filter ssh connections attempt from some hosts.
The list of these hosts is written in a text file.
due to the fact that these host may change i can't use etc/sshd_config file.
I also don't like modify ipfw configuration.
So I think that using TCP Wrapper with /etc/hosts.allow and hosts.deny can help me.
I've creaded /etc/hosts.allow and /etc/deny ... but ssh is ignoring them.
What do i have to do for activating TCP Wrapper.

I hope you can help me.
anyway thanks in advance
 
Top