admin_server probs

knasen

Registered
I have problem using CGI.

/cgi-bin/test-cgi is no problem accessing.

/cgi-bin/printenv results to:
SERVER_ADMIN [no address given]

This is the error I get when I try to access another cgi(admin pro):
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

How can I set server_admin address?
 

LunaMorena

Registered
it's in your apache conf file, if you can find it. Unfortunately i don't know where that is since it's not in a standard *nix location and it's not named httpd.conf like it would be on any other system.

That's something they should add to the GUI, even if they don't want to include advanced settings.
 

LunaMorena

Registered
Oh there it is, /Library/WebServer/Configuration/apache.conf

Look for "ServerAdmin". Take the # out from in front of it and put your email address where the dummy one is. save the file.

You have to be root to do that.

[Edited by LunaMorena on 10-14-2000 at 02:21 AM]
 

knasen

Registered
Ok...
I´ve done that, but I´m still having this same problem.
No server address?
Is there anything more I have to set in the apache.conf?

This is my error_log:
Premature end of script headers: /Library/WebServer/CGI-Executables/adminpro/adminpro.cgi

I have not done anything but change this:
Options Indexes FollowSymLinks MultiViews ExecCGI

And now the admin address of course..I can imagine there is much more changes in the configuration?

Is someone willing to help?
It would really help out =)

[Edited by knasen on 10-14-2000 at 01:02 PM]
 

LunaMorena

Registered
Well what I posted isn't going to help with the script you're having problems with... it's just going to set the server admin email address. :) Also, for that to take effect you have to either reboot the computer or turn the apache server off and then on again.

As for your script, I wouldn't be able to help figure out why it's not working without seeing both the script and its implementation, and even then I could be entirely useless. I'm mostly good at finding problems in my own, not other people's.
 

knasen

Registered
Ok...
Now I get the serveradmin address right =)
Just restarted..forgot that.
This cgi-problem seems to be hard getting figured out thow. I will have to keep looking...
Still getting this:

Premature end of script headers: /Library/WebServer/CGI-Executables/adminpro/adminpro.cgi
 

devnul

Registered
When you get the "premature end of headers" error, can you go to "view source" and see anything?.. Usually when I get this it means some non-header information has already been sent and then your script attempts to send a http header.... Let me know if you see anything with "view source"..

- Greg
 
Top