Adobe Update to Update problem on 10.4.1



I've posted this to the Adobe forums as well but thought you guys may be able to help as well.

Adobe Creative Suite has an application called Adobe Updater. You click it and it does basically what the Mac OSX update software app does: it finds the updates you need, pulls them over, and applies them.

Things were working fine. I upgraded to 10.4.1. I'm not sure if that has anything to do with the problem.

Now, update says it needs to update itself (which has happened before). It pulls over the update, mounts it, and tries to install it and errors out. A dialog box comes up. You can retry, retry later (which exists update but leaves the update on the drive), or quit (which exists and deletes the update). I've tried pulling over the update several times and get the same thing.

The update itself is a .dmg. I click it and mount it fine. It has a single file in it called AdobeUpdaterApp.framework. Inside that is Contents. Inside that is the usual looking stuff: .plist, MacOS directory, etc.

Is there a way to apply this update myself? Better yet, is there a log somewhere that may have some useful diagnostics?

Thanks to all.
The fix to this appears to be to create an admin user with file vault off.

One user discovered this while he was in safe mode. So, the initial solution was to boot into safe mode as a new admin user with file vault off and apply the update. But I tried it in normal mode and it worked for me.