AFP Service Dropping Users


I have a 10.3.9 Server running on a XServe Dual G4 1.33 with 1.5GB RAM.
It is bound to Active Directory. It uses AD for authentication only - no user management. I upgraded the Server Aug. 6. I have AFP, SMB, DNS (DNS slave) services running.

It has worked great until this Monday, Aug. 22. Mac users started telling me that their connections were seizing up. Their Macs do not lock up. Server just drops their connection. It does not drop all AFP connections. Those who got kicked out can log back in just as soon as they were dropped and keep going. I have mostly writers and designers at work who use MS Office and Adobe CS Suite 1.0. All Mac clients are on 10.3.8 or above. I have two Tiger users. Each is on 10.4.2.

I checked the Server. AFP service at the Server was still running okay. But the connections graph under Server Admin showed a dramatic drop in connections. I restarted the server today - Aug. 23 and forty minutes later when about 25 users are connected it drops half of them.

This is weird.

Thanks in advance.


The problem I think was not my XServe. It was IT's AD domain controller. It had some problems late Tues. and early Wedneday morning. When they said they had fixed it, I took a careful look at AFP services under Server Admin. The graph showed normal operation - 40 users and good throughput.

I called Apple about it. They suggested I run Hardware Test. You know - that CD you boot from and run an extended test. When the AFP services bombed Wednesday morning, the system log showed a error 11 or system implementation fault. I ran the test from 5 p.m. to about 8 p.m. The test froze. So I ran a quick test and all tests passed.

I think the server is okay now.


Today we had a problem, on a PMG5 10.4.2 Server, with AFP. It was having errors with AppleTalk and that. Couldn't initialize it or anything. My school called the Administrator to see if he could fix it, he said he'd have to re-install the server, and that he thought he did something to it. I download 10.4.2 Combined patch, patched it up, and had it working before the next class period. My teacher is still trying to get them to fire the previous Admin and hire me.


I'm Venting.

Sort of ironic for v.10.3x and 10.4.x Servers should have such difficulty with the file protocal freakin' Apple created? SMB services from my experience, runs smoother on Mac OS X Server than does AFP.

To recap - my XServe is on Mac OS 10.3.9.

AFP is a resource hog like a blood sucking leach. Check it out in top or the Activity Monitor and you will see that

AFP does not translate permissions all that well either. I have to be especially careful about setting permisssions. I have seen directories that have ignored permission settings from Workgroup Manager. I use Batchmod to correct permissions for those folders.

Tiger workstations cannot create folders on the Mac OS 10.3.9 Server for domain clients unless you set the owner of the share as root then chmod -R 2775. This was a surprise!!

Link -

Come on, Apple!! You're pissing me off.