Age of empires 2?

Soapvox

Want some of my Kool-aid?
Has anyone bought it yet (I have to wait til thursday), how is it? Is it a major improvement over the original (I love AOE1)? Please someone review it
 

evildan

Super Moderator
I'm installing Age of the Empires II on my mac tonight.

I've seen the PC version of it, which prompted me to get the mac version.

The guys are all about the same. The biggest difference would have to be the buildings. The buildings seem larger, more in scale with the people.

The addition of sheep was a wise one. You can click on the sheep and send them anywhere.... My 9 year old son suggested to me that I could use the sheep as scouts. Since Scouts reveal the map, and the loss of a sheep is much less of a concern then loosing an individual.

People can now go into buildings, the building displays a flag to indicate that someone is in it.

Not sure if you can go in every building, or just the town center.

The wounders are more wounderful.

Typing numbers in the chat invoke the game to make audio comments like "Start the Game already!" and "Raiding Party!"

I'll install it and give a more detailed review tomorrow.
 

Trip

Registered
It's good!
They showed some preview footage last year and everybody thought it was amazing! I, for one, didn't think it was amazing...I thought it was brilliant!

The gameplay has taken a huge step since AOE 1, and the graphics are doing great too, from what I've heard. It runs smoother than a babies bald head in OSX and I need to go get it now...BBL. :)
 

evildan

Super Moderator
Well I was up to 2am playing Age of the Empires II last night.

I was very happy with everything except the online gamming experience that I had. There is an online community of which the name escapes me, prpbably from lack of sleep. Anyway, you click on the button and it takes you to an IRC interface. You can then chat with other people and setup a game.

In doing so, I found that I had to update my version of Age of the Empires II. So after the update, I tryed to get a game going. I had no luck waiting for a game, so I decided to host my own. It was 10pm and I hadn't even played my first game yet.

I collected a few people and tryed to create a game. The IRC room where the people collected had a button called "start game" for me to click when I was ready to start hosting the event. I had this option becuase I set up the game.

The crowd I had was new to the game like me.. so we had a few problems.

After clicking "start game" my screen went blank and the game began to load. Age of the Empires II movies started up as normal, then I was brought to the opening screen where you can make game selections... then nothing.

I was at a loss... I tried to open up a multi-player game, but no one was joining. Since Age of the Empires II takes up the entire screen, I was unaware of the activity in the chat room I launched the game from. I waited a goot 3 full minutes, and nothing happened.

I aborted the game and found myself back in the chat room. Everyone was asking why I aborted the game. I told them I what happened. They all said they got a message saying "waiting for host" until I aborted the game.

Figuring it was a firewall issue, I decided to do it on my host machine. Same setup, almost the same crowd. The same thing happened. I was ready to combat the auto-launch flaw by giving the room my ip address. I told them to connect manually, if they were not taken to the game automatically.

This time we actually all got to the point where we were making game settings. We were at the screen where the host machine (mine) could change map size, etc.

Okay ready? yup we were all ready, and then at the launch of the game Age of the Empires crashed. Ouch! All this and no game yet!

I am on a mac, and using the same version of the game everyone else was using, but none of the machines on my network would automatically join games.

Frustrated, I tried a few other things out. I took two of my machines on my LAN and tried to play a multi-player game NOT using the online gamming service. It worked fine. Both machines responded correctly all the way up to and through the game.

Then I tried to create a game using the host computer on the gamming service - which name still escapes me. The game was set to have 2 players only. After the game was announced, I logged into it with my another machine on my network. So I had one game and two machines on the same LAN in the room.

When the host machine tried to launch the game, nothing happened again.

The only thing I can think of is that the gamming service program (the IRC app) was being run in classic and the Age of the Empires II game was actually running in osx. So the gamming app may have had a problem passing information to the osx version of the game.

One final note, I'm tired.
 

Crunchy in milk

Journey Agent
the only thing I truly like about aoe 2 is the possibility of this appearing for MAC sometime.

Star Wars battlegrounds uses a version of the age of empires (2) engine, which could mean that converting battlegrounds to mac is not such an impossibility. Westlake have ported Monkey Island 4 (Escape from monkey island) previously so there's more hope.
 

Machammer

Registered
Great game!! Played for a couple of days now. Had it give me a memory twice until I restarted OSX ( go figure). Haven't had any problems since. Though sometimes laying a wall longer than the shown screen can be painful.:)
 

evildan

Super Moderator
Well I have moved away from considering myself an Age of the Empires novice. I wouldn't consider myself an expert, just not a newbie anymore.

Although, now I make this post in frustration to the new addiction that has taken over my life. I have solved my online gamming problems, as previously posted above, by simply starting up in os9 and using the latest version of Game Ranger.

I am up to several games a night, when I play. It is always at least 2am before I find my eyes getting heavy. And 3am is my normal crash time.

I think I have a problem.

The other night, my girlfriend, who is also addicted to the game, was watching tv while I was playing online. We have two computers, but for some reason she was sitting the night out.

She said "look Dan, on TV, you're missing some mild porn."

There it was. My girlfriend spotting porn for me, and being considerate enough to point it out. Albeit only mild porn, porn notheless.

Now don't judge me as a pervert, becuase I am not, but as anyone with a girlfriend will tell you, when a girlfriend points out porn for you, it's not to be taken lightly.

My response was "ok, just let me finish attacking this castle and I'll be right there."

After the words had left my mouth, I realized my addiction to the game was unhealthy. It was as if someone else had spoken the response.

Ahh.... bitter failure. Another game was being played that night, a game of relations, a game of subtle hints, and don't forget the mild-porn; a game I lost becuase I didn't even play.

Oh, incase anyone is interested, my team won the online game I was playing and I made it to bed by 2:30am.

My girlfriend just emailed me as I am writing this post, I have not read the email yet, but the subject is "Sex or AOE?"
 

MACLOVA

Simply Mac-Loving
my online is so hard!!!! i can't figure how 2 configurate. maybe it is because i have the older vestoi which i play much much more... pleeeeeeez if any of you have the older version... how can i play multiplayer on it??? :confused: :p
 
Top