ahh web sharing problem

Tyness

Registered
hello, i just got around to updating my web sharing and its screwed web sharing up. it tries to start up and nothing happens. ive tried typing in various commands into console, none of them fix the problem.

below are three commands ive typed into console, yet none seem to work...

sudo perl -i.prefix -p -e 's/apple_hfs_module/hfs_apple_module/g' /etc/httpd/httpd.conf

mv /etc/httpd/httpd.conf /httpd.conf.pre_macosx10.1
mv /etc/httpd/httpd.conf.default /etc/httpd/httpd.conf

sudo perl -i.prefix -p -e 's/apple_hfs_module/hfs_apple_module/g' /etc/httpd/httpd.conf

thanks/ahhhh
 

skb104

Registered
I also have tried these fixes, as listed in the Stepwise article and other places, and am still not having any success. I've only had 10.1.1 for a few days, and have never had any version prior to that, so I'm a little lost. Do I have to be logged in as root to write into my httpd.conf file? I get read-only alert when I try to edit it, and I'm scared to mess with it via chmod commands.
 

Jadey

sosumi
You don't have to be logged in as root, but you do have to execute the commands as super user. You would type "sudo" (without the quotes) in the command line before making any changes to httpd.conf.

I have Apache working under 10.1.1 after following the recommendations at stepwise to get it working.
 
Top