airport / dhcp / 10.1

kev

Registered
Hi All

This is a similar/but different problem to that posted by kolbster.
My trouble is trying to get AirPort to pull in my DHCP settings. I can connect via ethernet no problem - all the settings are ok. When I switch the ethernet cable from my powerbook to the base station, it gives me an IP of 10.0.0.3 and a name server of 10.0.0.1 - and I'm not getting very far with these.
I'm have a cable modem connected to the RoadRunner service.

Any ideas? Muchos Gracias.

Kev.
 

FireWire

Registered
What you are seeing for an ip of 10.0.0.3 (or whatever) is from your AirPort base and is correct. You see, the base station will make new IP address (totally different from your normal road runner IP) with it's own internal DHCP server ? sharing your single road runner IP to all of the computers via the new numbers. All of the 10.0.0.x numbers will route out of the base station, through your modem correctly if the base station is set up correctly.

You need to launch the "AirPort Admin Utility" from the utilities folder inside you application folder on os 10.1.

From there, set the base station up with the proper IP address, or dhcp settings and apply those settings. You see, your airport will now have the exact settings that you computer used to have. And your computer should be able to access the net with the 10.0.0.x.

If your base station does not get it's IP address correctly, I need more info about the road runner service. Most importantly is your IP address assigned by a DHCP ID, or by the "MAC" hardware address (a unique hexadecimal number that identifies a specific network node) of the device. Also, where you able to connect to the net via the Base Station under any other os (10.0.4 or 9.2.1 etc).

good luck,

Tim
 

kev

Registered
Firewire,
Thanks for the reply. I'm not on my mac at the moment, but I've tried it so many times, I'm pretty sure I can describe it.

Firstly, in answer to your last question, I have only just acquired the airport, so no I've never had it working before on any OS (I get the exact same results when I try it in 9.2.1).

When I plug the ethernet cable directly into into the mac, I can set the connection type as: Built in Ethernet->DHCP and leave everything else to the server. Within a second, all the fields are populated.

From the Airport setup assistant, I set it up exactly the same way (get all the info from the DHCP server), but it's no go.

Hope this is enough info. If you need more let me know.

Thanks
Kev.
 

kev

Registered
back on my Mac.
the question was raised whether RoadRunner id'd me by DHCP ID or MAC address. Well, from where I' standing it's MAC. The DHCP Client ID field is empty and I have Hex Ethernet address displayed in the Network tab in the Sys Preferneces.

Any ideas what the next course of action is?

Kev.
 

Matrix Agent

Masochist Mascot
I also have RR under DHCP and Airport, so far it has worked withouyt a hitch. I find that when i recive a bad connection, i just tell the network panel to create a "new location" or "new profile" (not sure which it is) and I then proceed to reenter my settings and reconnect.

You dont add anything to the DHCP fields, do you?
I dont fill in any.

If you just added a router ect. to split your rr connection, mabey you should try messing around with that.
 

kev

Registered
Phil

I'm not putting anything in the DHCP setup and I haven't split the connection.
Can you compare your numbers to mine please - this is driving me mad!
When I connect direct to cable modem, my settings are:
IP 66.65.65.xxx
Sub: 255.255.255.0
Router: 66.65.65.xxx
DHCP Client ID: <empty>
Ethernet Addr: xx:xx:xx:xx:xx:xx

My airport base settings are:
IP: 192:42:249:xxx
Sub: 255.255.255.0
Router: <empty>
DNS: 10.0.1.1
Domain: <empty>
DHCP Client ID: <empty>

Switching to Airport network, my Network settings are:
IP: 10.0.1.3
Sub: 255.255.255.0
Router: 10.0.1.1
DHCP Client ID: <empty>
Airport ID: xy:xy:xy:xy:xy:xy

Does all this look cool??

Thx

Kev.
 

Matrix Agent

Masochist Mascot
yes, very close to identical. Try using the airport admin to return the base station to default? Not sure if that doesn't work..
 

Paul Derby

Registered
Kev,
Do you have more than one device you want to connect via the Airport? If you just have the one machine, then you can set up the Airport as a BRIDGE device rather than as a NAT or DHCP device. In bridging mode, the Airport just works as a wireless extension to your ethernet cable. Your machine will still get DHCP settings from the cable device.

I have 3 different LANs where I use Airports. In two of these locations there is a DHCP server already in place so the Airport is configured as a bridging device.

In the other location, the Airport has a pool of FIXED "real" IP addresses and is configured to dole out these addresses as requested.

Hope you get it working to your satisfaction soon!

Paul
 

kev

Registered
ok that's it. I'm ready to throw this wireless shit out the window. DHCP, manual, bridging - all no go.
WRT the bridging setup Paul suggested, I've tried a few configs but maybe someone can walk me thru an exact setup.
For the bridging set up, from the Airport Admin Util:
under the:
Internet Tab: should this remain DHCP?
Network tab: 'distribute network addresses' is switched off ('enable ethernet bridging' is grayed out but switched on atomatically)
Port Mapping is left empty.

Yours in serious desperation

K.
 

Paul Derby

Registered
When you bridge, the device you bridge to (or something connected to that device) is your DHCP server. All the Airport does is become a wireless extension to your normal ethernet cable.

Hope it starts working for you!
 
Top