Airport Express Problem


I recently purchase an aiport express to enable me to play itunes wirelessly through my ibook and play on my speakers connected to a sony reciever. When i first bought it, i hooked everything up and it worked. The next day my housemate decided to get a new router that is faster and i came home and it didn't work. He then proceded to password protect the network so nobody but our house could access it. I had an IT guy from my company come over and try to work with it but he couldnt figure it out. I've gone through the setup and everytime i get to the point where i choose the airport express that i want, nothing comes up, even when i rescan. The Airport Express just blinks amber, telling me that it isn;t connected. I have even tried plugging in the airport express while holding down the small reset button located on the actual unit.

Additionally, my laptop is located literally 2 feet away from the airport express and both of those are only a room away from the wireless router. If you could please advise me on this situation i would be highly appreciative. Thank you Very Much!


I had a little difficulty setting up airport express for itunes on an existing wireless network (Dlink DSL G604) with WPA security.
This is what I did and it worked. 1. Removed the WPA security (to none) 2. Hooked up the Airport express and during the setup installed the password that I intended to use on the WPA Personal 3. came up with the message that 'no connection could be made'. 4. Reinstalled WPA password on the Dlink network
Upon turning everything back on, the Airport express was fine